1023  Have Fun with Numbers (20分)

Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with kdigits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题意:给出一个不超过20位数的整数,将每位数都扩大2倍,有进位,判断这个整数两倍后的数位是否为原数位的一个排列。最后输出扩大后的整数

思路:用字符串输入,之后按位存储在数组a[]中,扩大2倍的数存储在数组b[]中,(要注意进位时从下标 1 处开始)用数组 b1[] 来标记数位出现的情况

AC代码 

#include<iostream>
using namespace std;
int main(){
	string s;
	cin >> s;
	int a[100], b[100]={0}, b1[100]={0}, flag = 1;
	for(int i = 0; i < s.length(); i++){
		a[i] = s[i]-'0';
		b[i] = a[i]*2; 
		b1[a[i]]++; 
	}
	for(int i = 1; i < s.length(); i++){
		if(b[i] >= 10){
			b[i-1] += b[i]/10;
			b[i] = b[i]%10;
		}
	}
	for(int i = 0; i < s.length(); i++){
		b1[b[i]]--;
	}
	for(int i = 0; i < 10; i++){
		if(b1[i] != 0){
			flag = 0;
			break;
		}
	}
	if(flag){
		cout << "Yes" << endl;
	}
	else{
		cout << "No" << endl;
	}
	for(int i = 0; i < s.length(); i++){
		cout << b[i];
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值