1029 Median

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

解析:一看正确率这么低,肯定坑很多。借用大佬的题解:

题解:
     第一个队列存好后,把第二个队列边读,边和第一个队列比较,选择出队。这样可以不用一次存完第二个队列,解决超内存的问题。

思路:
    第一、二个序列分别有n, m个元素,所以需要从队头剔除(n + m - 1) / 2个元素,
    最后答案就是两个队头的最小值。对于最终答案在第一第二个队列中的情况要分开处理。
    若答案在第二个队列中,在输入数据时就可以提前得出答案并退出,若答案在第一个队列中,要二次出队才能找到答案。
 

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

int main()
{
	int n,m,x,cnt=0;;
	queue<int> a;
	
	scanf("%d",&n);
	for(int i=0; i<n; i++)
	{
		scanf("%d",&x);
		a.push(x);
	}
	queue<int> b;
	a.push(inf);
	scanf("%d",&m);
	for(int i=0; i<m; i++)
	{
		scanf("%d",&x);
		b.push(x);
		if(cnt==(n+m-1)/2)
		{
			printf("%d\n",min(a.front(),b.front()));
			return 0;
		}
		if(a.front()<b.front())
			a.pop();
		else 
			b.pop();
		cnt++;
	}
	b.push(inf);
	for(;cnt<(n+m-1)/2; cnt++)
	{
		if(a.front()<b.front())
			a.pop();
		else 
			b.pop();
	}
	printf("%d\n",min(a.front(),b.front()));
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值