HDOJ 题目2277 Change the ball(水题,规律)

Change the ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 479    Accepted Submission(s): 166


Problem Description
Garfield has three piles of balls, each pile has unique color of following: yellow, blue, and red. Now we also know Garfield has Y yellow balls, B blue balls, and R red balls. But Garfield just wants to change all the balls to one color. When he puts two balls of different color togather, the balls then change their colors automatically into the rest color. For instance, when Garfield puts a red one and a yellow one togather, the two balls immediately owns blue color, the same to other situations. But the rule doesn’t work when the two balls have the same color.
  Garfield is not able to estimate the minimal steps to achieve the aim. Can you tell him?

 

Input
For each line, there are three intergers Y, B, R(1<=Y,B,R<=1000),indicate the number refered above.
 

Output
For each case, tell Garfield the minimal steps to complete the assignment. If not, output the symbol “):”.
 

Sample Input
  
  
1 2 3 1 2 2
 

Sample Output
  
  
): 2
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2273  2276  2274  2279  2275 
题目大意:就是他有r个红球,b个蓝球,y个黄球,两个不同颜色的球放在一起,后变成剩下的那种颜色,他想把所有的球都变成一种颜色,问需要多少步,
思路:当有两个球相等时,
#include<stdio.h>
#include<stdlib.h>
int cmp(const void *a,const void *b)
{
	return *(int *)a-*(int *)b;
}
int main()
{
	int a[5];
	while(scanf("%d%d%d",&a[1],&a[2],&a[3])!=EOF)
	{
		qsort(a+1,3,sizeof(a[1]),cmp);
		if(a[1]==a[2]||(a[2]-a[1])%3==0)
			printf("%d\n",a[2]);
		else
			if(a[3]==a[1]||a[2]==a[3]||(a[3]-a[2])%3==0||(a[3]-a[1])%3==0)
				printf("%d\n",a[3]);
			else
				printf("):\n");
	}
}

绝对可以,当有一个比另一大三的倍数也可以,想想就好
ac代码
#include<stdio.h>
#include<stdlib.h>
int cmp(const void *a,const void *b)
{
	return *(int *)a-*(int *)b;
}
int main()
{
	int a[5];
	while(scanf("%d%d%d",&a[1],&a[2],&a[3])!=EOF)
	{
		qsort(a+1,3,sizeof(a[1]),cmp);
		if(a[1]==a[2]||(a[2]-a[1])%3==0)
			printf("%d\n",a[2]);
		else
			if(a[3]==a[1]||a[2]==a[3]||(a[3]-a[2])%3==0||(a[3]-a[1])%3==0)
				printf("%d\n",a[3]);
			else
				printf("):\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值