HDOJ 题目2818 Building Block(带权值并查集)



Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3061    Accepted Submission(s): 927


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.  
C X : Count the number of blocks under block X  

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2819  2817  2821  2820  2822 
 

ac代码

#include<stdio.h>
#include<string.h>
int num[300300],pre[300300],rank[300300],t;
void init()
{
	int i;
	for(i=0;i<=t;i++)
	{
		pre[i]=i;
		num[i]=1;
		rank[i]=0;
	}
}
int find(int x)
{
	int t;
	if(x!=pre[x])
	{
		t=pre[x];
		pre[x]=find(t);
		rank[x]+=rank[t];
	}
	return pre[x];
}
int main()
{
	int i,a,b,fa,fb;
	char c;
	while(scanf("%d",&t)!=EOF)
	{
		init();
		for(i=0;i<t;i++)
		{
			getchar();
			scanf("%c",&c);
			if(c=='M')
			{
				scanf("%d%d",&a,&b);
				fa=find(a);
				fb=find(b);
				if(fa!=fb)
				{
					pre[fa]=fb;
					rank[fa]=num[fb];
					num[fb]+=num[fa];
					num[fa]=0;
				}
			}
			else
				if(c=='C')
				{
					scanf("%d",&a);
					find(a);//重要,更新节点
					printf("%d\n",rank[a]);
				}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值