HDOJ 2818 Building Block (带权并查集)


BuildingBlock

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5537    Accepted Submission(s): 1707

Problem Description

John are playing with blocks.There are N blocks (1 <= N <= 30000) numbered 1...NInitially, there are N piles, and each pile contains one block. Then Johndo some operations P times (1 <= P <= 1000000). There are two kinds ofoperation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If Xand Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.

 

 

Input

The first line containsinteger P. Then P lines follow, each of which contain an operation describeabove.

 

 

Output

Output the count for each Coperations in one line.

 

 

Sample Input

6

M 1 6

C 1

M 2 4

M 2 6

C 3

C 4

 

 

Sample Output

1

0

2


#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<(b);++i)
const int maxn = 30005;
const int mod = 200907;
#define ll long long
#define rush() int t;scanf("%d",&t);while(t--)
int pre[maxn],under[maxn],num[maxn];
void init()
{
    f(i,0,maxn)
    {
        pre[i]=i;
        under[i]=0;
        num[i]=1;
    }
}
int find(int x)
{
    if(pre[x]==x)
        return x;
    else
    {
        int t=find(pre[x]);
        under[x]+=under[pre[x]];
        pre[x]=t;
        return t;
    }
}
void join(int x,int y)
{
    int a=find(x);
    int b=find(y);
    if(a!=b)
    {
        under[a]=num[b];
        num[b]+=num[a];
        //num[a]+=num[b];
        pre[a]=b;
    }
}
int main()
{
    int p;
    char s[3];
    int a,b;
    while(~scanf("%d",&p))
    {
        init();
        while(p--)
        {
            scanf("%s",s);
            if(s[0]=='M')
            {
                scanf("%d%d",&a,&b);
                join(a,b);
            }
            else
            {
                scanf("%d",&a);
                find(a);
                printf("%d\n",under[a]);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值