HDOJ 题目2669 Romantic(拓展的欧几里得,模板)

95 篇文章 0 订阅

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3149    Accepted Submission(s): 1243


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
  
  
77 51 10 44 34 79
 

Sample Output
  
  
2 -3 sorry 7 -3
 

Author
yifenfei
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2668  2671  2670  2672  2673 
 
ac代码
#include<stdio.h>
#include<string.h>
__int64 exgcd(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		return a;
	}
	else
	{
		__int64 d=exgcd(b,a%b,x,y);
		__int64 t=x;
		x=y;
		y=t-a/b*y;
		return d;
	}
}
int main()
{
	__int64 a,b,x,y;
	while(scanf("%I64d%I64d",&a,&b)!=EOF)
	{
		__int64 d=exgcd(a,b,x,y);
		if(1%d)
			printf("sorry\n");
		else
		{
			while(x<0)
			{
				x+=b;
				y-=a;
			}
			printf("%I64d %I64d\n",x,y);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值