HDOJ题目3018 (欧拉回路)

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1686    Accepted Submission(s): 653


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.

题意:一笔画。。问最少几笔能画完。。

分析:

如果是个欧拉回路一笔就可以完成,如果是个其它连通集,要根据这个集合的奇度数而定,笔划数=奇度数/2,用并查集来判断有多少个连通集,然后用ans来存这些连通集,通过判断度数是奇偶性来确定是否为欧拉回路;总之笔划数 = 奇度数/2 + 欧拉回路数;

ac代码
#include<stdio.h>
#include<string.h>
int n,m;
int deg[100005],v[100005],ans[100005],odd[100005],f[100005];
void init(int n)
{
	int i;
	for(i=0;i<=n;i++)
	{
		v[i]=deg[i]=odd[i]=0;
		f[i]=i;
	}
}
int find(int x)
{
	int r=x;
	while(r!=f[r])
		r=f[r];
	return r;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,k=0,sum=0;
		init(n);
		while(m--)
		{
			int a,b,fa,fb;
			scanf("%d%d",&a,&b);
			fa=find(a);
			fb=find(b);
			deg[a]++;
			deg[b]++;
			f[fa]=fb;
		}
		for(i=1;i<=n;i++)
		{
			int f=find(i);
			if(!v[f])
			{
				v[f]=1;
				ans[k++]=f;
			}
			if(deg[i]&1)
				odd[f]++;
		}
		for(i=0;i<k;i++)
		{
			j=ans[i];
			if(deg[j]==0)
				continue;
			if(odd[j]==0)
				sum++;
			else
			{
				sum+=odd[j]/2;
			}
		}
		printf("%d\n",sum);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值