HDOJ3018 欧拉回路

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3317    Accepted Submission(s): 1324


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   3013  3015  3016  3011  3010 

假如连通分量是个孤立的点,需要零笔。
假如连通分量是个(半)欧拉图,需要一笔。
假如连通分量是个非(半)欧拉图,需要笔数为该图中奇数度点的数目/2

用一个num数组统计每个连通分量的个数。
假如num【i】==0,表示该节点不是根节点。 
假如num【i】==1 表示该节点孤立存在。
假如num【i】>1,再分是否为(半)欧拉图计算结果。

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn = 1e5+5;
int du[maxn],f[maxn],num[maxn],odd[maxn];
int i,j,k,n,m,cnt,a,b;

int Find(int x){
    if (f[x]==x) return x;
    return f[x] = Find(f[x]);
}

void Merge(int x, int y){
   int fx = Find(x), fy = Find(y);
   if (fx!=fy){
      f[fx]=fy;
   }
}

int main(){
    while (~scanf("%d%d",&n,&m)){
         for (i=1; i<=n; i++) {
            du[i] = 0;
            odd[i] = 0;
            f[i] = i;
            num[i] = 0;
         }

         for (i=1; i<=m; i++) {
            scanf("%d%d",&a,&b);
            du[a]++;
            du[b]++;
            Merge(a,b);
         }

         for (i=1; i<=n; i++) num[Find(i)]++;
         for (i=1; i<=n; i++) if (du[i]&1) odd[Find(i)]++;


         cnt = 0;
         for (i=1; i<=n; i++) if (num[i]>1){
                if (odd[i]>0) cnt+=odd[i]/2;
                else cnt++;
         }
         printf("%d\n",cnt);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值