HDOJ 3018 Ant Trip(欧拉回路判断几笔画问题)

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2178    Accepted Submission(s): 845


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 

题意:有n个点,m条边,问用几次可以把所有边画完(画过的边不能再画,注意是画完所有的边)

题解: 并查集+欧拉回路。分析:

①若连通分量是一个单独的点,没有边,需要0笔画。
②若连通分量是一个欧拉图或者半欧拉图,则需要1笔。
③若连通分量是一个非(半)欧拉图,则需要的笔画=该图中奇度数的点的数量/2

我们用数组degree[i]来记录i的度数。 用num[i]来记录以i为根的连通分量的点的个数,当num[i]==0时表示i不是连通分量的根,当num[i]==1时,表示该连通分量是一个孤立的点。这两种情况下笔画都不增加。 我们用ood[i]来表示以i为根的来连通分量中奇数度的点的个数。 当num[i]>1&&odd[i]==0时该连通分量为(半)欧拉图,只需要一笔。  当num[i]>1&&odd[i]>0时,为非(半)欧拉图,需要ood[i]/2笔。

代码如下:

#include<cstdio>
#include<cstring>
#define maxn 100010 
int tree[maxn];
int num[maxn],odd[maxn],degree[maxn];

int find(int x)
{
	if(x==tree[x])
		return x;
	return tree[x]=find(tree[x]);
}

void merge(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
		tree[fa]=fb;
} 

int main()
{
	int n,m,i,j,u,v,ans;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;++i)
			tree[i]=i;
		memset(degree,0,sizeof(degree));
		memset(num,0,sizeof(num));
		memset(odd,0,sizeof(odd));
		while(m--)
		{
			scanf("%d%d",&u,&v);
			degree[u]++;
			degree[v]++;
			merge(u,v);
		}
		for(i=1;i<=n;++i)
		{
			num[find(i)]++;//根节点所在的连通分量上的点个数加一 
			if(degree[i]%2)
				odd[find(i)]++;//find(i)为根节点的连通分量奇数度点加一 
		}
		ans=0;
		for(i=1;i<=n;++i)
		{
			if(num[i]>1&&odd[i]==0)
				ans++;
			else if(num[i]>1&&odd[i]>0)
				ans+=odd[i]/2;
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值