HDOJ 题目3415 Max Sum of Max-K-sub-sequence(单调队列求区间和最大值)

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6698    Accepted Submission(s): 2460


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

Sample Input
  
  
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

Sample Output
  
  
7 1 3 7 1 3 7 6 2 -1 1 1
 

Author
shǎ崽@HDU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3423  3417  3418  3419  3421 
题目大意:输入n,k,含有一个n个数的序列,序列是成环的,问区间最大的和是多少,起点和终点是哪(题目上说的是起点和长度啊,但是看样例像是终点啊,不知道反正过了。。),
ac代码

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int sum[100100<<1];
int q[100010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,k;
		scanf("%d%d",&n,&k);
		int i;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&sum[i]);
			sum[i+n]=sum[i];
		}
		n+=k;
		for(i=1;i<=n;i++)
			sum[i]+=sum[i-1];
		int j;
		int front,rear;
		front=0;
		rear=-1;
		int ans=-INF;
		int l,r;
		l=r=0;
		for(i=1;i<=n;i++)
		{
			for(;front<=rear&&q[front]<i-k;front++);
			for(;front<=rear&&sum[q[rear]]>=sum[i-1];rear--);
			q[++rear]=i-1;
			if(ans<sum[i]-sum[q[front]])
			{
				ans=sum[i]-sum[q[front]];
				l=q[front]+1;
				r=i;
			}
		}
		n-=k;
		if(r>n)
			r-=n;
		printf("%d %d %d\n",ans,l,r);
	}
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值