ZOJ 题目3777 Problem Arrangement(状态压缩DP)

Problem Arrangement

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution

Author: DAI, Longao

Source: The 11th Zhejiang Provincial Collegiate Programming Contest

题目大意:给你一个n,m,后边一个n*n的矩阵,表示第i个工作第j个做的价值使map【i】【j】,让你求,做完这些工作获得的总价值大于等于m的概率

ac代码

40835742015-10-07 15:40:49Accepted 3777C++103035372略懂_is_a_Joker

#include<stdio.h>
#include<string.h>
#define LL long long
LL dp[1<<13][550];
LL map[13][13];
LL fun(int n)
{
	LL ans=1;
	for(LL i=1;i<=n;i++)
		ans*=i;
	return ans;
}
LL gcd(LL a,LL b)
{
	if(a<b)
	{
		LL t=a;
		a=b;
		b=t;
	}
	if(b==0)
	{
		return a;
	}
	return gcd(b,a%b);
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		int i,j,k;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				scanf("%lld",&map[i][j]);
		memset(dp,0,sizeof(dp));
		dp[0][0]=1;
		for(i=0;i<=(1<<n);i++)
		{
			int temp=0;
			for(j=1;j<=n;j++)
			{
				if(i&(1<<(j-1)))
					temp++;
			}
			for(j=1;j<=n;j++)
			{
				if(i&(1<<(j-1)))
					continue;
				for(k=0;k<=m;k++)
				{
					if(k+map[temp+1][j]>=m)
						dp[i|(1<<(j-1))][m]+=dp[i][k];
					else
						dp[i|(1<<(j-1))][k+map[temp+1][j]]+=dp[i][k];
				}
			}
		}
		if(dp[(1<<n)-1][m]==0)
			printf("No solution\n");
		else
		{
			LL N=fun(n);
			LL g=gcd(N,dp[(1<<n)-1][m]);
			printf("%lld/%lld\n",N/g,dp[(1<<n)-1][m]/g);
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值