ZOJ3776-Problem Arrangement

Problem Arrangement

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution

Author:  DAI, Longao
Source:  The 11th Zhejiang Provincial Collegiate Programming Contest


题意:有n(1<=n<=12)道ACM题目。每道题目放在不同的位置都有一个happy值。以n*n矩阵给出。第i行第j列的值表示第i个为题放在第j个位置的happy值p[i][j](0<=p[i][j]<=100)。现在有个人写了个随机算法。问你他要得到一个happy值不小于m(1<=m<=500)的排列。问他生成次数的期望

解题思路:如果知道他一次随机生成的序列为满足条件的序列的概率p。那么期望E=1/p了。而p又为满足条件的方案数/总发难数。最简单粗暴的方法就是dfs暴力每种选择然后统计满足条件的方案数。但是dfs时间复杂度为O(n!),明显超时的节奏。题目中限制每行每列只能选择一个,用状压来记录已经选择的列。dp[i][j]表示。目前列的选择状态为i,happy值为j的方案数。i中二进制位中k位为1表示第k列已经选择。需要注意的是这里不用枚举行数。因为i中1的个数就可以代表行数了。递推时只需根据1的个数就可确定了。这样就不会出现某一行重复选多次的情况


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int dp[1<<13][510];
int f[13];
int a[13][13];

void init()
{
    f[1]=1;
    for(int i=2;i<13;i++)
        f[i]=f[i-1]*i;
}

int gcd(int x,int y)
{
    if(x>y) return gcd(y,x);
    while(y%x)
    {
        int k=y%x;
        y=x;
        x=k;
    }
    return x;
}

int main()
{
    int t,m,n;
    scanf("%d",&t);
    init();
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&a[i][j]);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=0;i<(1<<n);i++)
        {
            int tmp=0;
            for(int j=1;j<=n;j++)
                if(i&(1<<(j-1))) tmp++;
            for(int j=1;j<=n;j++)
            {
                if(i&(1<<(j-1))) continue;
                for(int k=0;k<=m;k++)
                {
                    if(k+a[tmp+1][j]>=m) dp[i|(1<<(j-1))][m]+=dp[i][k];
                    else dp[i|(1<<(j-1))][k+a[tmp+1][j]]+=dp[i][k];
                }
            }
        }
        if(dp[(1<<n)-1][m]==0) printf("No solution\n");
        else
        {
            int k=gcd(f[n],dp[(1<<n)-1][m]);
            printf("%d/%d\n",f[n]/k, dp[(1<<n)-1][m]/k);
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值