HDOJ 题目1576 A/B(拓展欧几里得求乘法逆元)

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3310    Accepted Submission(s): 2511


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

Output
对应每组数据输出(A/B)%9973。
 

Sample Input
  
  
2 1000 53 87 123456789
 

Sample Output
150714922015-10-11 12:04:40Accepted15760MS1396K550 BG++Who_you?

#include<stdio.h>
#include<string.h>
#define mod 9973
#define LL __int64
LL ex_gcd(LL a,LL b,LL &x, LL &y)
{
	if(b==0&&a==0)
		return -1;
	if(b==0)
	{
		x=1;
		y=0;
		return a;
	}
	else
	{
		LL d=ex_gcd(b,a%b,x,y);
		LL t=x;
		x=y;
		y=t-a/b*y;
		return d;
	}
}
LL mod_re(LL a,LL n)
{
	LL x,y;
	LL d=ex_gcd(a,n,x,y);
	if(d==1)
		return (x%n+n)%n;
	return -1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		LL n,b;
		scanf("%I64d%I64d",&n,&b);
		LL x=mod_re(b,mod);
		printf("%I64d\n",n*x%mod);
	}
}


  
  
7922 6060
 

Author
xhd
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1788  1124  1319  1370  1930 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值