version `ZLIB_1.2.3.4' not found 解决方法

出现的错误

caffe 之前都能正常运行,不知何种原因出现以下错误:

[root@Master pro1]# ./caffe train -sovler examples/mnist/train_lenet.sh
./caffe: /lib64/libz.so.1: version `ZLIB_1.2.3.4’ not found (required by /root/anaconda2/lib/./libpng16.so.16)

解决方法

安装个新版的zlib

get http://zlib.net/zlib-1.2.8.tar.gz
tar zxf zlib-1.2.8.tar.gz
cd zlib-1.2.8
./configure
make && make install
cp /usr/local/lib/libz.so.1.2.8 /lib64/
cd /lib64/
rm libz.so.1
ln -s libz.so.1.2.8 libz.so.1

没有更多推荐了,返回首页