hdu4651

Partition

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1099    Accepted Submission(s): 648


Problem Description
How many ways can the numbers 1 to 15 be added together to make 15? The technical term for what you are asking is the "number of partition" which is often called P(n). A partition of n is a collection of positive integers (not necessarily distinct) whose sum equals n.

Now, I will give you a number n, and please tell me P(n) mod 1000000007.
 

Input
The first line contains a number T(1 ≤ T ≤ 100), which is the number of the case number. The next T lines, each line contains a number n(1 ≤ n ≤ 10 5) you need to consider.

 

Output
For each n, output P(n) in a single line.
 

Sample Input
      
      
4 5 11 15 19
 

Sample Output
      
      
7 56 176 490
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   5717  5716  5715  5714  5713 
题意:数字k写成和的形式,有多少种情况例如:
4 = {4}  {1,3} {2,2} {1,1,2} {1,1,1,1} 共五种情况

在51 node上看到的这道题,标签是dp,但是确实是数学公式题,欧拉函数的倒数是 整数的划分的母函数

 

   其中为k的分割函数。    至于问什么是,我也不知道--

欧拉函数及其展开式是这样的

 

 

这个展开式的指数广义五边形数  为1 2 5 7 12 15 22 26

  ↓

为五边形数  1, 5, 12, 22, 35, 51, 70, ...

 



                                

把欧拉函数乘到右边展开  

#include <iostream>


using namespace std;
const int maxn=1e5+50,mod=1e9+7;
int dp[maxn],temp[maxn];
void init()
{
    int t=1000;
    for(int i=-1000;i<=1000;i++)
    {
        temp[i+t]=i*(3*i-1)/2;
    }
    dp[0]=1;
    for(int i=1;i<maxn;i++)
    {
        dp[i]=0;


        for(int j=1;j<=i;j++)
        {
            if(temp[t+j]<=i)
            {
                if(j&1)dp[i]+=dp[i-temp[t+j]];
                else
                    dp[i]-=dp[i-temp[t+j]];
            }
            else
                break;
                dp[i]=(dp[i]%mod+mod)%mod;
            if(temp[t-j]<=i)
            {
                if(j&1)
                    dp[i]+=dp[i-temp[t-j]];
                else
                    dp[i]-=dp[i-temp[t-j]];
            }
            else
                break;


        }
          dp[i]=(dp[i]%mod+mod)%mod;
    }
}
int main()
{
    int t;
    int n;
    cin>>t;
    init();
    while(t--)
    {
        cin>>n;
        cout<<dp[n]<<endl;
    }
    return 0;
}

在 n>0 时,等式右侧的系数均为0,比较等式二侧的系数,可得
 

p(n) - p(n-1) - p(n-2) + p(n-5) + p(n-7) + \cdots=0

 

因此可得到分割函数p(n)的递归式:p(n) = p(n-1) + p(n-2) - p(n-5) - p(n-7) + \cdots


#include <iostream>

using namespace std;
const int maxn=1e5+50,mod=1e9+7;
int dp[maxn],temp[maxn];
void init()
{
    int t=1000;
    for(int i=-1000;i<=1000;i++)
    {
        temp[i+t]=i*(3*i-1)/2;
    }
    dp[0]=1;
    for(int i=1;i<maxn;i++)
    {
        dp[i]=0;

        for(int j=1;j<=i;j++)
        {
            if(temp[t+j]<=i)
            {
                if(j&1)dp[i]+=dp[i-temp[t+j]];
                else
                    dp[i]-=dp[i-temp[t+j]];
            }
            else
                break;
                dp[i]=(dp[i]%mod+mod)%mod;
            if(temp[t-j]<=i)
            {
                if(j&1)
                    dp[i]+=dp[i-temp[t-j]];
                else
                    dp[i]-=dp[i-temp[t-j]];
            }
            else
                break;

        }
          dp[i]=(dp[i]%mod+mod)%mod;
    }
}
int main()
{
    int t;
    int n;
    cin>>t;
    init();
    while(t--)
    {
        cin>>n;
        cout<<dp[n]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值