1083. List Grades (25)
Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.
Input Specification:
Each input file contains one test case. Each case is given in the following format:
N name[1] ID[1] grade[1] name[2] ID[2] grade[2] ... ... name[N] ID[N] grade[N] grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.
Output Specification:
For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.
Sample Input 1:4 Tom CS000001 59 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95 60 100Sample Output 1:
Mike CS991301 Mary EE990830 Joe Math990112Sample Input 2:
2 Jean AA980920 60 Ann CS01 80 90 95Sample Output 2:
NONE
/*************************************************************************
> File Name: 1083.c
> Author: YueBo
> Mail: yuebowhu@163.com
> Created Time: Sun 14 May 2017 08:26:46 PM CST
************************************************************************/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct student
{
char name[16];
char id[16];
int score;
};
int main()
{
int N;
int i;
char name[16];
char id[16];
int score, down_score, up_score;
int flag = 0;
scanf("%d", &N);
struct student stu_array[101];
for (i = 0; i < 101; i++)
{
stu_array[i].score = -1;
}
for (i = 0; i < N; i++)
{
scanf("%s%s%d", name, id, &score);
stu_array[score].score = score;
strcpy(stu_array[score].name, name);
strcpy(stu_array[score].id, id);
}
scanf("%d%d", &down_score, &up_score);
for (i = 100; i >= 0; i--)
{
if (stu_array[i].score >= down_score && stu_array[i].score <= up_score)
{
printf("%s %s\n", stu_array[i].name, stu_array[i].id);
flag = 1;
}
}
if (flag == 0)
printf("NONE\n");
return 0;
}