poj 3041-Asteroids-最小顶点覆盖

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11259 Accepted: 6107

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 


题目意思: 用最少的木板覆盖X,样例中我们只要用一块横的,一块竖的木板就好了。这题也是二分匹配题目的模版题
因为X所在的位置为(1,1)也就是相当于1和1匹配,(1,3)说明1和3匹配,画个表格就知道了。
行列分别匹配,具体二分匹配的定义刘汝佳的书上很详尽了

见代码:
#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

#define MX 555
int n, m, e;
bool g[MX][MX], v[MX];
int match[MX];

bool find(int x) {
	for(int i = 1; i <= n; ++i) {
		if(!v[i] && g[x][i]) {
			v[i] = 1;
			if(match[i] == -1 || find(match[i])) {
				match[i] = x;
				return 1;
			}
		}
	}
	return 0;
}

void hungary() {
	int ans = 0;
	for(int i = 1; i <= n; ++i) {
		memset(v, 0, sizeof(v));
		if(find(i)) ans ++;
	}
	printf("%d\n", ans);
}
int main() {	
	int cas;
	while (scanf("%d%d", &n, &m) != EOF){
		memset(g, 0, sizeof(g));
		memset(match, -1, sizeof(match));
		int a, b;
		for(int i = 1; i <= m; ++i) {
			scanf("%d%d", &a, &b);
			g[a][b] = 1;
		}
		hungary(); 
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值