思科模拟器中的交换机使用方法

思科模拟器中的交换机使用方法

思科模拟器中有较多种交换机型号,这里只是简单的介绍一下二层交换机2960,以及三层交换机中的3560

1.关于交换机的原理:

交换机是通过其保存的MAC地址表来进行工作的,而其地址表的内容大概是这样的:交换机中的MAC地址表
交换机中的MAC地址表
 交换机通过将PC的MAC地址与本身的接口号 一 一 对应来实现PC之间的信息交换。这个MAC地址通过交换机不断学习来形成的。交换机的学习过程大概是这样的:PC1要发送信息给PC2,当PC1将信息送到交换机之后,交换机便会将PC1的MAC地址与其对应的接口记录下来,假如此时交换机没有在自己的MAC地址表中找到PC2的地址怎么办呢?他会向所有已连接的接口进行广播:“我现在要找一个MAC地址为XXX的PC,收到请回复” 此时所有与交换机连接的PC收到广播后会做出不同的反应,若不是目标地址的PC收到该广播后,不会做出反应,装作没听到。而PC2收到该广播后,则会回复交换机:“我在这” 此时交换机便会将其MAC地址与对应的接口号记录到MAC地址表中,如果PC1与PC2还要通讯的话,交换机通过查询MAC地址表已经知道二者的MAC地址与对应的接口号,那么便会直接通过单播来实现两者之间的通讯。交换机正式通过不断地广播学习这个过程,来不断增加自己MAC地址表中的内容。
 但是在交换机中的MAC地址表是动态的,存在一个老化时间老化时间默认为300秒。从一个地址记录加入地址表以后开始计时,如果在老化时间内各端口未收到源地址为该MAC地址的帧,那么,这些地址将从动态转发地址表(由源MAC地址、目的MAC地址和它们相对应的交换机的端口号)中被删除。静态MAC地址表不受地址老化时间影响。但是如果交换机又收到某个MAC地址相关的交换帧,那么这个MAC地址的老化时间又会再次刷新为300秒
 MAC地址表的查询:在交换机的特权模式下:switch# show mac-address-table 【dynamic】

2.交换机的各种模式:

交换机各种模式简介
(1)用户模式:switch>
(2)特权模式:switch>enable
        switch#
(3)全局模式:switch#config termal
       switch(config)#
(4)接口模式:switch(config)#interface fastethernet 0/1 //进入接口0/1
           switch(config-if)#
(5)返回上一模式: exit

3.交换机的双工:

duplex:配置双工模式的关键字
full:将接口的双工模式指定为全双工
全双工
half:将接口的双工模式指定为半双工
半双工
auto:将接口的双工模式指定自动
一般交换机会自动处于自动模式。配置端口的双工模式时要进入到接口模式。

5.二层交换机 以 2960-24TT为例

(1)同一网段的电脑互相连接如图:

简单的同网段相连
图中PC标识即为其IP 下同
简单的同网段相连的话,直接用直通线将PC与交换机连接,然后给PC配上相同网段的IP即可互相通信,可以使用PC中的ping命令简单检测网络是否通畅。

(2)同一网段如何划分VLAN:

实验图如下:

划分VLAN实验图划分两个VLAN

Switch(config)#vlan 2
Switch(config-vlan)#exit 
Switch(config)#vlan 3
Switch(config-vlan)#exit 

查看VLAN信息:
查看VLAN信息
可以看到除了划分的VLAN2跟VLAN3之外,还有一个VLAN1,VLAN1是交换机默认的一个VLAN,也就是说初始化状态下所有的端口都在同一个VLAN下。
所以初始状态下各个PC是能够互相联通的,用PC1去pingPC2:PC1pingPC2
可以看到,是能够ping通的。接下来将其与交换机连接的接口划分到不同的VLAN:

Switch(config)#interface fastEthernet 0/1         #进入接口1
Switch(config-if)#switchport access vlan 2         #将接口1划分到VLAN2

此时PC1所连接的接口1便划分到了VLAN2中 而PC2连接的接口2 还在默认的VLAN1中,也就是说此时已经成为不在同一VLAN中的两台PC。在不同VLAN中的PC是无法通信的。
不同VLAN无法互相通信
用PC1去ping PC2的结果
在实际应用中通过划分VLAN可以实现相同部门之间可以互相通讯,而不同部门之间无法互相通讯,从而实现隔绝的效果。
也可以同时将多个接口划分到同一个VLAN:

Switch(config)#interface range fastEthernet0/1-10               #同时进入接口1-10
Switch(config-if-range)#switchport  access vlan 2               #加入VLAN2
Switch(config-if-range)#exit 
Switch(config)#exit 
Switch#show vlan brief                                          #查看各VLAN情况

范围划分VLAN
可以看到接口1-10全被划分到了VLAN2

(3)同一网段多个交换机相同VLAN的通讯(trunk):

实际应用中同一个部门的员工可能会距离比较远,此时可能要通过多个交换机连接,即不同交换机的相同VLAN的通讯。
不同交换机相同VLAN的通讯
图中PC均在同一网段PC1.10与PC1.30同在VLAN 2
PC1.20与PC1.40同在VLAN1
交换机switch0与switch1通过接口24相连接
交换机switch1的配置:

Switch(config)#interface fastEthernet 0/1         #进入接口1
Switch(config-if)#switchport access vlan 2         #将接口1划分到VLAN2
% Access VLAN does not exist. Creating vlan 2        #划分VLAN时VLAN没有提前建立,则自动建立
Switch(config-if)#exit 
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk            #将接口模式更改为trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
                                                          #提示接口成功开启
Switch(config-if)#

交换机switch0的配置与交换机1相同。
注意:在将接口模式转换为trunk时,二层交换机与三层交换机是不同的,二层交换机不用选择接口的封装类型,下面三层交换机时再说。
配置完成之后,相同VLAN的PC之间便可以互相通信了
相同VLAN不同交换机通讯
同为VLAN2的PC1.10与PC1.30通信

(4)交换机的虚接口:

可以通过VLAN交换机的接口配置IP地址,也就是将VLAN当做是一个接口,来为其配置IP地址,此时的VLAN便可以看作是一个虚拟接口。下面说一下如何给虚接口配置IP地址:

Switch(config)#interface vlan2  #将VLAN2看作虚接口进入
Switch(config-if)#ip address 192.168.1.1  255.255.255.0   #为虚接口VLAN1配置IP地址跟子网掩码
Switch(config-if)#no shutdown    #开启虚拟接口,默认关闭
Switch(config-if)#exit 
Switch(config)#exit 
Switch#show running-config  #查看运行配置
Building configuration...

Current configuration : 1076 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 2
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
... ...
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!

interface Vlan2
ip address 192.168.1.1 255.255.255.0
  #可以看到VLAN2有IP地址了而VLAN1没有IP地址并且处于默认的关闭状态

!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end


Switch#

6.三层交换机 以 3560-24PS为例

(1)实现不同网段不同VLAN之间的通信

三层交换机具备路由功能,所以能实现两个VLAN之间的互相访问,此时的每一个VLAN虚接口就是该网段的网关
实验图:
三层交换机
二层交换机有两个VLAN,分别是VLAN1,VLAN2。
PC1.10与二层交换机的f0/1口连接
PC2.10与二层交换机的f0/2口连接
二层交换机与三层交换机通过f0/24口连接

二层交换机的配置:

Switch#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastEthernet 0/2  #进入接口2
Switch(config-if)#switchport access vlan 2 #将接口2划分到VLAN2
Switch(config-if)#exit 
Switch(config)#interface fastEthernet 0/24 #进入接口24
Switch(config-if)#switchport mode trunk  #接口模式转换为trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up #
Switch(config-if)#

三层交换机配置:

Switch>enable 
Switch#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface vlan 1 #进入虚机接口VLAN1
Switch(config-if)#ip address 192.168.1.1 255.255.255.0  #配置IP跟子网掩码
Switch(config-if)#no shutdown  #打开虚拟接口
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up #提示虚拟接口打开
Switch(config-if)#exit 
Switch(config)#vlan 2
Switch(config-vlan)#exit 
Switch(config)#interface vlan 2   #进入虚机接口VLAN2
Switch(config-if)#ip address 192.168.2.1 255.255.255.0  #配置IP跟子网掩码
Switch(config-if)#no shutdown   #打开虚拟接口
Switch(config-if)#exit
Switch(config)#ip routing #打开三层交换机的路由功能
Switch(config)#interface fastEthernet 0/24 #进入接口24
Switch(config-if)#switchport trunk encapsulation dot1q  #指定接口的封装方式为802.1q
Switch(config-if)#switchport mode trunk   #转换为trunk模式
Switch(config-if)#

将PC1.10的默认网关设置为192.168.1.1
将PC2.10的默认网关设置为192.168.2.1
用PC1.10去pingPC2.10:
PC1 ping PC2

再说一种三层交换机与路由器相连的情况吧。

实例如图:
三层交换机与路由器连接
就接这上面三层交换机的的第一个例子做了,给三层交换机直接连了一个路由器。
三层交换的的f0/23口与路由器的f0/1口连接
三层交换机的的配置在上面的配置基础上再加上:

Switch>enable
Switch#configure terminal 
Switch(config)#interface fastEthernet 0/23
Switch(config-if)#no switchport 
Switch(config-if)#ip address 192.168.4.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#exit 
Switch(config)#ip route 192.168.3.0 255.255.255.0 192.168.4.2 

路由器配置:

Router>enable
Router#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Router(config-if)#exit 
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit 
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1 #因为目标网段有两个网段所以用了默认路由

此时用PC1.10去pingPC3.10
pc1 ping pc3
显示两个PC可以通信。
由此更能显示出三层交换机能够实现路由器的一些功能。
好了关于思科模拟器中的交换机就简单介绍到这里了,如果有什么说的不正确的地方,希望大家多多指正,有什么疑问的话也可以联系我。
在这里插入图片描述

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页