PKU 2356 Find a multiple

2014-8-1
 
Language:
                                                                                                                                 Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5942 Accepted: 2585 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3
 
/*
此题的判断方法是用抽屉原理
此题一定有解,不存在输出0的结果!

证明如下

我们可以依次求出a[0],a[0]+a[1],a[0]+a[1]+a[2],......,a[0]+a[1]+a[2]...+a[n];

假设分别是sum[0],sum[1],sum[2],......,sum[n]

如果在某一项存在是N的倍数,则很好解,即可直接从第一项开始直接输出答案

但如果不存在,则sum[i]%N的值必定在[1,N-1]之间,又由于有n项sum,有抽屉原理:

 把多于n个的物体放到n个抽屉里,则至少有一个抽屉里有2个或2个以上的物体。

则必定有一对i,j,使得sum[i]%N=sum[j]%N,其中i!=j,不妨设j>i

则(sum[j]-sum[i])%N=0,故sum[j]-sum[i]是N的倍数

则只要输出从i+1~j的所有的a的值就是答案

其实做法可以有两个方向,一个是判断余数是否为0,有0直接输出就好,没0在判断sum[]余数相等的情况,然后输出
另一个方向是出来输出一个数据的情况直接输出就好,其他的都找余数相等就行,然后找到就直接输出结果
一:
#include<stdio.h>
#include<string.h>
int main()
{
  int sum[1001000],flag[10010],a[10010],str[10010];
  int n,i,j,t;
  while(scanf("%d",&n)!=EOF)
  {
    memset(sum,0,sizeof(sum));
    memset(flag,0,sizeof(flag));
    for(i=1;i<=n;i++)
      scanf("%d",&a[i]);
    for(i=1;i<=n;i++)
    {
          sum[i]=sum[i-1]+a[i];
          t=sum[i]%n;
          if(t==0)     //余数是0,输出就好 
           {
              printf("%d\n",i);
              for(j=1;j<=i;j++)
               printf("%d\n",a[j]);
               break;
           }
           else             //余数不是0,标记余数,没标记的就标记为1,如果已经被标记过,说明找到了 
           {
             if(flag[t]==0)
               {
                  flag[t]=1;
                  str[t]=i;
               }
             else
             {
                printf("%d\n",i-str[sum[i]%n]);
                for(j=str[sum[i]%n]+1;j<=i;j++)
                  printf("%d\n",a[j]);
                  break;
             }   
           }
     }         
  }    
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值