poj_3370 Halloween treats

  2014-8-1  17:47                                                                                                                          Halloween treats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6530 Accepted: 2409 Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

/*输出很随意,满足的输出一组就行*/

 

 

代码如下:

#include<stdio.h>
#include<string.h>
#define maxn 100000+100
int a[maxn],flag[maxn],which[maxn];
long long int sum[maxn];      //按最大的界限算一下就超过int型了   直接定义long long就行 
int main()
{
    int i,j,chi,n,y;
    while(~scanf("%d%d",&chi,&n)&&!(chi==0&&n==0))
    {
       memset(a,0,sizeof(a));
       memset(which,0,sizeof(which));
       memset(flag,0,sizeof(flag));
       memset(sum,0,sizeof(sum));
       for(i=1;i<=n;i++)
         scanf("%d",&a[i]);
       for(i=1;i<=n;i++)
       {
         sum[i]=sum[i-1]+a[i];
         y=sum[i]%chi;
         if(y==0)
         {
            for(j=1;j<i;j++)
              printf("%d ",j);   //这次输出的是第几个数,而非这个数本身,要注意 
            printf("%d\n",j);
            break;
         }
         else 
         {
            if(flag[y]==0)
            {
               flag[y]=1;
               which[y]=i;
            }
            else
            {
                for(j=which[sum[i]%chi]+1;j<i;j++)
                  printf("%d ",j);
                printf("%d\n",j);
                break;
            }
         }
       }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值