hdu2141 Can you find it? (二分查找)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 19334    Accepted Submission(s): 4860


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2289  1597  1551  2298  1399 
 

解析:我们先预处理出a数列与b数列能够形成的所有数,存储在q数组当中,然后对q数组进行排序。
           对于每一个X,我们枚举c[i],然后在q数组中二分查找是否存在X-c[i],若存在,则“YES”,否则“NO”。
代码:
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=5e2;
int a[maxn+10],b[maxn+10],c[maxn+10];
int q[maxn*maxn+10];

bool find(int x)
{
  int l=1,r=q[0],mid;
  while(l<=r)
    {
      mid=(l+r)>>1;
      if(q[mid]==x)return 1;
      if(q[mid]<x)l=mid+1;
      else r=mid-1;
	}
  return 0;
}

int main()
{
  freopen("1.in","r",stdin);
  
  int sum=0,i,j,k,s,x;
  while(scanf("%d%d%d",&a[0],&b[0],&c[0])==3)
    {
      printf("Case %d:\n",++sum);
      for(i=1;i<=a[0];i++)scanf("%d",&a[i]);
      for(i=1;i<=b[0];i++)scanf("%d",&b[i]);
      for(i=1;i<=c[0];i++)scanf("%d",&c[i]);
      for(q[0]=0,i=1;i<=a[0];i++)
        for(j=1;j<=b[0];j++)q[++q[0]]=a[i]+b[j];
      sort(q+1,q+1+q[0]);
      k=q[0],q[0]=1;
      for(i=2;i<=k;i++)if(q[i]!=q[i-1])q[++q[0]]=q[i];
      k=c[0],c[0]=1;
      for(i=2;i<=k;i++)if(c[i]!=c[i-1])c[++c[0]]=c[i];
      
	  scanf("%d",&s);
	  for(i=1;i<=s;i++)
	    {
	      scanf("%d",&x);
	      for(j=1;j<=c[0];j++)if(find(x-c[j]))break;
	      printf("%s\n",(j<=c[0])?"YES":"NO");
		}      
	}
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
1. 智慧社区背景与挑战 随着城市化的快速发展,社区面临健康、安全、邻里关系和服务质量等多方面的挑战。华为技术有限公司提出智慧社区解决方案,旨在通过先进的数字化技术应对这些问题,提升城市社区的生活质量。 2. 技术推动智慧社区发展 技术进步,特别是数字化、无线化、移动化和物联化,为城市社区的智慧化提供了可能。这些技术的应用不仅提高了社区的运行效率,也增强了居民的便利性和安全性。 3. 智慧社区的核心价值 智慧社区承载了智慧城市的核心价值,通过全面信息化处理,实现对城市各个方面的数字网络化管理、服务与决策功能,从而提升社会服务效率,整合社会服务资源。 4. 多层次、全方位的智慧社区服务 智慧社区通过构建和谐、温情、平安和健康四大社区模块,满足社区居民的多层次需求。这些服务模块包括社区医疗、安全监控、情感沟通和健康监测等。 5. 智慧社区技术框架 智慧社区技术框架强调统一平台的建设,设立数据中心,构建基础网络,并通过分层建设,实现平台能力及应用的可持续成长和扩展。 6. 感知统一平台与服务方案 感知统一平台是智慧社区的关键组成部分,通过统一的RFID身份识别和信息管理,实现社区服务的智能化和便捷化。同时,提供社区内外监控、紧急救助服务和便民服务等。 7. 健康社区的构建 健康社区模块专注于为居民提供健康管理服务,通过整合医疗资源和居民接入,实现远程医疗、慢性病管理和紧急救助等功能,推动医疗模式从治疗向预防转变。 8. 平安社区的安全保障 平安社区通过闭路电视监控、防盗报警和紧急求助等技术,保障社区居民的人身和财产安全,实现社区环境的实时监控和智能分析。 9. 温情社区的情感沟通 温情社区着重于建立社区居民间的情感联系,通过组织社区活动、一键呼叫服务和互帮互助平台,增强邻里间的交流和互助。 10. 和谐社区的资源整合 和谐社区作为社会资源的整合协调者,通过统一接入和身份识别,实现社区信息和服务的便捷获取,提升居民生活质量,促进社区和谐。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值