HDU 2141 Can you find it? 二分查找

原题: http://acm.hdu.edu.cn/showproblem.php?pid=2141

题目:

Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 17902 Accepted Submission(s): 4515

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output
Case 1:
NO
YES
NO

思路:

四个数组,a,b,c,x。
第一排分别输入a的元素个数,b的元素个数,c的元素个数。
后面三排输入abc分别有哪些元素。
后面一排输入x的元素个数。
后面则输入x分别有哪些元素。

暴力解法就是三重for循环,枚举所有情况是否满足和等于x。
显然,500*500*500*1000是要超时的。

因为a+b+c=x,变形可得a+b=x-c,虽然感觉这并没有什么用,但是请注意内存限制,10 000kb,而500*500*500是125 000 kb,内存超出限制。
而我们变形之后,左边是250kb,右边是500kb,不会超出内存限制。

处理完空间后,时间也会超时,因为我们需要寻找的是两边能否找出相等值,对于右边的每一个值,左边只需要用二分查找,需要用的时间是500*1000*log250000 大概等于10^7,并不会超时。

代码:

#include <iostream>
#include"string.h"
#include"cstdio"
#include"stdlib.h"
#include"algorithm"
using namespace std;

const int N = 505;
int l,n,m;
int a[N];
int b[N];
int c[N];
int ab[N*N];
int ff[1005];
int flag[1005];
int f;
int cishu=1;
void init()
{
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(c,0,sizeof(c));
    memset(ab,0,sizeof(ab));
    memset(ff,0,sizeof(ff));
    memset(flag,0,sizeof(flag));
}
void input()
{
    for(int i=1; i<=l; i++)
    {
        scanf("%d",&a[i]);
    }
    for(int i=1; i<=n; i++)
    {
        scanf("%d",&b[i]);
    }
    for(int i=1; i<=m; i++)
    {
        scanf("%d",&c[i]);
    }
    scanf("%d",&f);
    for(int i=1;i<=f;i++)
    {
        scanf("%d",&ff[i]);
    }

}

void func()
{
    int k=0;
    for(int i=1;i<=l;i++)
    {
        for(int j=1;j<=n;j++)
        {
            ab[k]=a[i]+b[j];
            k++;
        }
    }
    sort(ab,ab+k);
    for(int i=1;i<=f;i++)
    {
        for(int j=1;j<m;j++)
        {
            int temp=ff[i]-c[j];
            int pos=lower_bound(ab,ab+k,temp)-ab;
            if(ab[pos]==temp)
            {
                flag[i]=1;
                break;
            }
        }
    }
}

void print()
{
    printf("Case %d:\n",cishu);
    cishu++;
    for(int i=1;i<=f;i++)
    {
        if(flag[i])
            printf("YES\n");
        else
            printf("NO\n");
    }
}

int main()
{
    while(scanf("%d %d %d",&l,&n,&m)!=EOF)
    {
        init();
        input();
        func();
        print();
    }
}




















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
1. 智慧社区背景与挑战 随着城市化的快速发展,社区面临健康、安全、邻里关系和服务质量等多方面的挑战。华为技术有限公司提出智慧社区解决方案,旨在通过先进的数字化技术应对这些问题,提升城市社区的生活质量。 2. 技术推动智慧社区发展 技术进步,特别是数字化、无线化、移动化和物联化,为城市社区的智慧化提供了可能。这些技术的应用不仅提高了社区的运行效率,也增强了居民的便利性和安全性。 3. 智慧社区的核心价值 智慧社区承载了智慧城市的核心价值,通过全面信息化处理,实现对城市各个方面的数字网络化管理、服务与决策功能,从而提升社会服务效率,整合社会服务资源。 4. 多层次、全方位的智慧社区服务 智慧社区通过构建和谐、温情、平安和健康四大社区模块,满足社区居民的多层次需求。这些服务模块包括社区医疗、安全监控、情感沟通和健康监测等。 5. 智慧社区技术框架 智慧社区技术框架强调统一平台的建设,设立数据中心,构建基础网络,并通过分层建设,实现平台能力及应用的可持续成长和扩展。 6. 感知统一平台与服务方案 感知统一平台是智慧社区的关键组成部分,通过统一的RFID身份识别和信息管理,实现社区服务的智能化和便捷化。同时,提供社区内外监控、紧急救助服务和便民服务等。 7. 健康社区的构建 健康社区模块专注于为居民提供健康管理服务,通过整合医疗资源和居民接入,实现远程医疗、慢性病管理和紧急救助等功能,推动医疗模式从治疗向预防转变。 8. 平安社区的安全保障 平安社区通过闭路电视监控、防盗报警和紧急求助等技术,保障社区居民的人身和财产安全,实现社区环境的实时监控和智能分析。 9. 温情社区的情感沟通 温情社区着重于建立社区居民间的情感联系,通过组织社区活动、一键呼叫服务和互帮互助平台,增强邻里间的交流和互助。 10. 和谐社区的资源整合 和谐社区作为社会资源的整合协调者,通过统一接入和身份识别,实现社区信息和服务的便捷获取,提升居民生活质量,促进社区和谐。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值