hdu1385 Minimum Transport Cost (floyd输出字典序最小的路径)

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9313    Accepted Submission(s): 2480


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1142  1548  2544  2066  1874 
 

解析:path[i][j]记录从 i 到 j 的最短路的第一个点。

代码:

#include<cstdio>
using namespace std;

const int inf=0x7fffffff;
const int maxn=2e2;
int a[maxn][maxn],b[maxn];
int path[maxn][maxn];

int main()
{
  //freopen("1.in","r",stdin);
  
  int n,i,j,k,s,e;
  while(scanf("%d",&n),n)
    {
      for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
          {
		    scanf("%d",&a[i][j]);
		    if(a[i][j]<0)a[i][j]=inf;
		    path[i][j]=j;
		  }
	  for(i=1;i<=n;i++)scanf("%d",&b[i]),a[i][i]=0;
	  
	  for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)if(a[i][k]<inf && i!=k)
          for(j=1;j<=n;j++)if(a[k][j]<inf && j!=k && j!=i)
		    {
		      s=a[i][k]+a[k][j]+b[k];
		      if(a[i][j]<s)continue;
		      if(a[i][j]>s){a[i][j]=s;goto d1;}
			  if(path[i][j]>path[i][k])d1:path[i][j]=path[i][k];
			}
	  while(scanf("%d%d",&s,&e),s>0)
	    {
	      printf("From %d to %d :\n",s,e);
	      printf("Path: %d",k=s);
	      while(k!=e)printf("-->%d",k=path[k][e]);
          printf("\nTotal cost : %d\n\n",a[s][e]);
		}
	}
  return 0;
}



基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip 个人大四的毕业设计、课程设计、作业、经导师指导并认可通过的高分设计项目,评审平均分达96.5分。主要针对计算机相关专业的正在做毕设的学生和需要项目实战练习的学习者,也可作为课程设计、期末大作业。 [资源说明] 不懂运行,下载完可以私聊问,可远程教学 该资源内项目源码是个人的毕设或者课设、作业,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96.5分,放心下载使用! 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),供学习参考。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值