Wormholes POJ 3259【SPFA】

http://poj.org/problem?id=3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES
 
 
/*
题目大意:虫洞问题,现在有n个点,m条边,
代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,
现在在地上出现了w个虫洞,
虫洞的意义就是你从a到b花费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到从前

其实就是判断是否存在负环 
*/
#include <cstdio>
#include <cstring>
#include <queue>
#define MAXN 550
#define MAXM 10000
#define INF 0x3f3f3f3f
using namespace std;
struct Edge
{
	int u, v, w;
	int next;//下一个结构体变量的下标 
}edge[MAXM];
int head[MAXN];//下标为起点u,值为对应结构体下标 
int vis[MAXN];//判断是否加入队列了 
int used[MAXN];
int num;
int N;
int low[MAXN];//存最短路径 
void Add_Edge(int u, int v, int w)//加边 
{
	Edge E={u, v, w, head[u]};//初始化结构体 
	edge[num]=E;//直接赋值 
	head[u]=num++;
}
bool SPFA(int s)
{
	int i, j;
	queue<int> Q;
	memset(low, INF, sizeof(low)); 
	memset(vis, 0, sizeof(vis));
	memset(used,0,sizeof(used));	
	vis[s] = 1;
	low[s]=0; 
	Q.push(s);
	used[s]++;
	while(!Q.empty())
	{
		int u=Q.front();
		Q.pop();
		vis[u]=0;//出队列了,不在队列就变成0 
		for(j = head[u]; j != -1; j = edge[j].next)
		{
			int v = edge[j].v;
			if(low[v] > low[u] + edge[j].w)
			{
				low[v] = low[u] + edge[j].w;
				if(!vis[v] )				 
			 	{
			 		vis[v]=1;
			 		Q.push(v);
			 		used[v]++;
			 		if(used[v]>N) return 0;
			 	}
			}
		}
	}
	return 1;
}
int main()
{
	int u, v, w;
	int T;
	int M, W;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d", &N, &M, &W);
		memset(head, -1, sizeof(head));
		num=0;
		while(M--)
		{
			scanf("%d%d%d", &u, &v, &w);
			Add_Edge(u, v, w);
			Add_Edge(v, u, w);//无向边 
		}	
		while(W--)
		{
			scanf("%d%d%d", &u, &v, &w);
			Add_Edge(u, v, -w);
		}	
		if(!SPFA(1)) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值