Choose the best route HDU杭电2680【dijkstra算法 || SPFA】

http://acm.hdu.edu.cn/showproblem.php?pid=2680

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

//这种方法可以多个起点找最短路径,省时间

//Dijkstra

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int map[1010][1010];
int dis[20200];
bool used[20200];
int n;
int e;
int dijkstra()
{
	int i,j;
	memset(used,0,sizeof(used));
	for(i=0;i<=n;++i)
		dis[i]=INF;
	int pos;
	for(i=0;i<=n;++i)//第一次给dis赋值 
	{
		dis[i]=map[0][i];
	}
	dis[0]=0;
	used[0]=1;
	for(i=0;i<n;++i)//最多运行n次 
	{
		int min=INF;
		for(j=0;j<=n;++j)
		{
			if(!used[j]&&dis[j]<min)
			{
				min=dis[j];
				pos=j;
			}
		} 
		used[pos]=1;
		if(pos==e) return dis[pos];
		for(j=0;j<=n;++j)//把dis数组更新,也叫松弛
		{
			if(!used[j]&&dis[j]>map[pos][j]+dis[pos])
			{
				dis[j]=map[pos][j]+dis[pos];
			}
		}
	}
	return -1;
}
int main()
{
	int m,s,T;
	int u,v,w;
	int temp;
	int i,j;
	while(~scanf("%d%d%d",&n,&m,&e))
	{		
		for(i=0;i<=n;++i)
      		for(j=0;j<=i;++j)
        		map[i][j]=map[j][i]=INF;
		for(i=1;i<=m;++i)
		{
			scanf("%d%d%d",&u,&v,&w);
			if(map[u][v]>w)
				map[u][v]=w;
		}		
		scanf("%d",&T);
		for(i=1;i<=T;++i)
		{
			scanf("%d",&temp);
			map[0][temp]=0;//0指向要找的原点 
		}
		int ans=dijkstra();//万能源点0 
		if(ans==-1)printf("-1\n");
		else printf("%d\n",ans);
	}
	return 0;
}

//SPFA


#include <cstdio>
#include <cstring>
#include <queue>
#define MAXN 1100
#define MAXM 22000
#define INF 0x3f3f3f3f
using namespace std;
int map[MAXN][MAXN];
int vis[MAXN];//判断是否加入队列了 
int num;
int low[MAXM];//存最短路径 
int e;
int M, N;
void SPFA()
{
	int i, j;
	queue<int> Q;
	memset(low, INF, sizeof(low)); 
	memset(vis, 0, sizeof(vis));	
	vis[0] = 1;
	low[0] = 0;
	Q.push(0);
	while(!Q.empty())
	{
		int u = Q.front();
		Q.pop();
		vis[u] = 0;//出队列了,不在队列就变成0 
		for(i = 1; i <= N; ++i)
		{
			
			if(low[i] > low[u] + map[u][i])
			{
				low[i] = low[u] + map[u][i];
				if(!vis[i])				 
			 	{
			 		vis[i]=1;
			 		Q.push(i);
			 	}
			}
		}
	}
	if(low[e] == INF) printf("-1\n");
	else printf("%d\n",low[e]);
}
int main()
{
	int u, v, w;
	while(~scanf("%d%d%d", &N, &M, &e))
	{
		for(int i=0; i<=N;++i)
			for(int j=0;j<=i;++j)
				map[i][j]=map[j][i]=INF;
		while(M--)
		{
			scanf("%d%d%d", &u, &v, &w);
			if(map[u][v]>w)//一定要判重 
				map[u][v]=w;
//			map[u][v]=w;
//			map[v][u]=w;
		}
		int T,s;
		scanf("%d",&T);	
		while(T--)
		{
			scanf("%d",&s);
			map[0][s]=0;//万能源点 
		}	
		SPFA();
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值