http://poj.org/problem?id=3187
Backward Digit Sums
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 5684 | Accepted: 3293 |
Description
FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:
Write a program to help FJ play the game and keep up with the cows.
3 1 2 4 4 3 6 7 9 16Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.
Write a program to help FJ play the game and keep up with the cows.
Input
Line 1: Two space-separated integers: N and the final sum.
Output
Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16
Sample Output
3 1 2 4
Hint
Explanation of the sample:
There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
//STL next_permutation
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int arr[1010];
int a[1010][1010];
int n,m;
int fun(int *array)
{
for(int i=1;i<=n;++i)
{
a[1][i]=array[i-1];
}
for(int i=2;i<=n;++i)
{
for(int j=1;j<=n-i+1;++j)
{
a[i][j]=a[i-1][j]+a[i-1][j+1];
}
}
// for(int i=1;i<=n;++i)
// {
// for(int j=1;j<=n-i+1;++j)
// printf("%d ",a[i][j]);
// puts("");
// }
return a[n][1];
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<n;++i)
{
arr[i]=i+1;
}
if(fun(arr)==m)
{
for(int i=0;i<n-1;++i)
{
printf("%d ",arr[i]);
}
printf("%d\n",arr[n-1]);
}
int num;
while(next_permutation(arr,arr+n))
{
num=fun(arr);
if(num==m)
{
for(int i=0;i<n-1;++i)
{
printf("%d ",arr[i]);
}
printf("%d\n",arr[n-1]);
break;
}
}
}
return 0;
}