UVA-1587 Box

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input
Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 ≤ w,h ≤ 10000) — width and height of the pallet in millimeters respectively.

Output
For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not possible to do so.

Sample Input
1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output
POSSIBLE
IMPOSSIBLE

分析:本体重点在于如何判断两个矩形全等,以及是否能组成长方体(不同矩形的长与宽必有一组相等)。

Source:

#include<stdio.h>
#include<stdlib.h>
struct pallet
{
    int w,h;
};
int is_same(struct pallet a,struct pallet b)
{
    if(a.w==b.w&&a.h==b.h)
        return 1;
    else
        return 0;
}
int main()
{
    struct pallet p[6],temp;
    int i,j,t;
    while(scanf("%d%d",&p[0].w,&p[0].h)!=EOF)
    {
        if(p[0].w<p[0].h)
        {
            t=p[0].w;
            p[0].w=p[0].h;
            p[0].h=t;
        }
        for(i=1;i<6;i++)
        {
            scanf("%d%d",&p[i].w,&p[i].h);
            if(p[i].w<p[i].h)
            {
                t=p[i].w;
                p[i].w=p[i].h;
                p[i].h=t;
            }
        }
        for(i=0;i<5;i++)
            for(j=0;j<5-i;j++)
                if(p[j].w<p[j+1].w)
                {
                    temp=p[j];
                    p[j]=p[j+1];
                    p[j+1]=temp;
                }
        for(i=0;i<5;i++)
            for(j=0;j<5-i;j++)
                if(p[j].w==p[j+1].w&&p[j].h<p[j+1].h)
                {
                    temp=p[j];
                    p[j]=p[j+1];
                    p[j+1]=temp;
                }
        for(i=0;i<6;i+=2)
            if(!is_same(p[i],p[i+1]))
                break;
        if(i==6&&(p[0].w==p[2].w)&&((p[4].w==p[0].h&&p[4].h==p[2].h)||(p[4].w==p[2].h&&p[4].h==p[0].h)))
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值