UVA-10892 LCM Cardinality

A pair of numbers has a unique LCM but a single number can be the LCM of more than one possible pairs. For example 12 is the LCM of (1, 12), (2, 12), (3,4) etc. For a given positive integer N, the number of different integer pairs with LCM is equal to N can be called the LCM cardinality of that number N. In this problem your job is to find out the LCM cardinality of a number.

Input
The input file contains at most 101 lines of inputs. Each line contains an integer N (0 < N ≤ 2∗109). Input is terminated by a line containing a single zero. This line should not be processed.

Output
For each line of input except the last one produce one line of output. This line contains two integers N and C. Here N is the input number and C is its cardinality. These two numbers are separated by a single space.

Sample Input
2
12
24
101101291
0

Sample Output
2 2
12 8
24 11
101101291 5

分析:将n质因数分解,得到n=lcm(a,b)=(p1^r1)(p2^r2)(p3^r3)…(pm^rm),pm小于n。其中,ri=max(ai,bi)。若ai=ri,则bi有ri+1种可能性,若bi=ri,则ai有ri+1种可能性,除去ai=bi=ri,总共有2*ri+1种情况。若n是素数,则ri=0。由于a,b可以互换,则ans=ans/2+1(考虑a=b)。

Source:

#include<stdio.h>
int main()
{
    int n,m,c,p,count,ans;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            return 0;
        m=n;
        ans=1;
        for(p=2;p<n;p+=2)             //质因数分解
        {
            count=0;
            while(n%p==0)
            {
                count++;
                n/=p;
            }
            ans*=2*count+1;
            if(p==2)
                p--;
        }
        if(n>1)                       //考虑n是素数的情况
            ans*=3;
        ans=ans/2+1;                  //除去a=b的情况
        printf("%d %d\n",m,ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值