1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

题目要求:给出两个多项式,求它们的乘积

#include<iostream>
using namespace std;
struct Polynomials{
	int exponents;
	double coefficients;
};
struct Polynomials p1[20];
//注意此处,本想题目告知指数最大为1000,但是在多项式相乘时指数最大可达到2000 ,由于开始时数组大小不合适所以导致段错误 
struct Polynomials res[2010];
void Initial(){
	for(int i=0;i<2010;i++){
		res[i].exponents=-1;
	}
}
int main(){
	int pnum1,pnum2;
	int exp;
	double coe;
	double c;
	int e;
	int count=0;
	while(scanf("%d",&pnum1)!=EOF){
		Initial();
		count=0;
		//读入第一个多项式 
		for(int i=0;i<pnum1;i++){
			cin>>p1[i].exponents>>p1[i].coefficients;  
		}
		cin>>pnum2;
		for(int i=0;i<pnum2;i++){//逐个读入第二个多项式的值 
			cin>>exp>>coe;
		    for(int j=0;j<pnum1;j++){
		    	e=exp+p1[j].exponents;//相乘结果的指数 
				c=coe*p1[j].coefficients;//相乘结果的系数
				if(c!=0){
				     if(res[e].exponents==-1){
					     count++;
					     res[e].exponents=e;
					     res[e].coefficients=c;  
				     } 
				     else{
					     res[e].coefficients+=c;  
					     if(res[e].coefficients==0){
					     	count--;
					     	res[e].exponents=-1;  
						 }
				     } 	
			   }
			}	
		}
		cout<<count;
		for(int i=2009;i>=0;i--){
			if(res[i].exponents>=0){
				 printf(" %d %.1f",res[i].exponents,res[i].coefficients); 
			}
		} 
		cout<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值