PAT 1127. ZigZagging on a Tree (30) 建树+双端队列 随后再看

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
 
 
建过100次的树没啥可说的。感觉自己的输出有点麻烦,应该有更简单的方法。随后在看看
#include <iostream>
#include<stdio.h>
#include<queue>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<set>
#include<deque>
#include<queue>
using namespace std;

struct
{
   int lc=-1;
   int rc=-1;
   int value;
}node[50];
int p=0;
int a[50],b[50];

int buildtree(int h1,int t1,int h2,int t2)
{
    if(h1>t1) return -1;
    if(h1==t1)
    {
        node[p].lc=node[p].rc=-1;
        node[p++].value=a[h1];
        return p-1;
    }
    int pp=h1;
    while(a[pp]!=b[t2]) pp++;
    int x=buildtree(h1,pp-1,h2,h2+pp-h1-1);
    int y=buildtree(pp+1,t1,h2+pp-h1,t2-1);
    node[p].lc=x;
    node[p].rc=y;
    node[p++].value=b[t2];
    return p-1;
}

void levelorder(int sta)
{
    deque<int> Q;
    Q.push_back(sta);
    int flag=0;
    int kongge=0;
    int p1=0,p2=1;
    while(!Q.empty())
    {
        int tmp;
        if(flag==1)
        {
            tmp=Q.front();
        Q.pop_front();
        }
        else
        {
            tmp=Q.back();
            Q.pop_back();
        }
        if(kongge==1) cout<<' ';
        kongge=1;
        p1++;
        cout<<node[tmp].value;
        if(flag==1)
        {
            if(node[tmp].lc!=-1) Q.push_back(node[tmp].lc);
            if(node[tmp].rc!=-1) Q.push_back(node[tmp].rc);
        }
        else
        {
            if(node[tmp].rc!=-1) Q.push_front(node[tmp].rc);
            if(node[tmp].lc!=-1) Q.push_front(node[tmp].lc);
        }
        if(p1==p2)
        {
           flag=(flag+1)%2;
            p2=Q.size();
            p1=0;
        }

    }


}

int main()
{
   int n;
   cin>>n;
    for(int i=0;i<n;i++)
     cin>>a[i];
     for(int i=0;i<n;i++)
     cin>>b[i];
    int start=buildtree(0,n-1,0,n-1);
    levelorder(start);

   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值