1127 ZigZagging on a Tree(DFS、BFS)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题目大意及思路

给出一棵树的中序遍历序列和后序遍历序列,按zig-zag的顺序输出其层序遍历序列。
首先递归建树,方法不多说(这里我一开始忘了返回BT,提交以后显示所有测试点都是段错误,百思不得其解,才发现是这么蠢的低级错误。。。)。层序遍历时记录层数,当队列中结点对应层数为偶数时(除了0层),倒序输出队列中所有结点,反之正序输出。由于queue无法进行反向访问,我用了数组表示队列。

AC代码

#include <iostream>
using namespace std; 

typedef struct node{
	int data;
	node *lchild, *rchild;
}*BTree, BNode;
const int maxn = 101;
int n, in[maxn], post[maxn];

BTree create(int l1, int h1, int l2, int h2){
	//[l1,h1]为中序序列,[l2,h2]为后序序列
	if(l1 > h1) return NULL;
	BTree BT = new node;
	BT->data = post[h2];
	int k = l1; //找到中序序列中根结点的位置
	while(in[k] != post[h2]) k++;
	int num = k - l1; //左子树结点数量
	BT->lchild = create(l1, k - 1, l2, l2 + num - 1);
	BT->rchild = create(k + 1, h1, l2 + num, h2 - 1);
	return BT; 
}

void levelorder(BTree &BT){
	int front = -1, rear = -1;
	node* Q[maxn];
	Q[++rear] = BT;
	cout<<BT->data;
	int level = 0, last = 0;
	while(front < rear){
		node* t = Q[++front];
		if(t->lchild != NULL) 
			Q[++rear] = t->lchild;
		if(t->rchild != NULL) 
			Q[++rear] = t->rchild;
		if(front == last){
			level++;
			last = rear;
			if(level != 0 && level % 2 == 0){ //逆序 
				for(int i = rear; i > front; i--)
					cout<<" "<<Q[i]->data;
			}
			else{ //顺序
				for(int i = front + 1; i <= rear; i++)
					cout<<" "<<Q[i]->data; 
			}
		}
	}
} 

int main(){
	cin>>n;
	for(int i = 0; i < n; i++)
		cin>>in[i];
	for(int i = 0; i < n; i++)
		cin>>post[i];
	BTree BT = create(0, n - 1, 0, n - 1);
	levelorder(BT);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值