PAT 1129. Recommendation System (25) 数数

1129. Recommendation System (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目是最大的障碍,看了半天才懂。就是输出 输入次数最多的那些数字。建立一个maxx[],最大的数字都放进去,每轮输出一次。
没敢用set,怕超时。不过看了下别人的用set也能过

#include <iostream>
#include<stdio.h>
#include<queue>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<set>
#include<deque>
#include<queue>
using namespace std;

struct ZZ
{
    int value;
    int cnt;
};

int mark[50005]={0};
ZZ maxx[15];
int last;

void goin(int x,int k)
{
   mark[last]++;
   int p=0;
   while(p<k)
   {
       if(mark[last]>maxx[p].cnt||(mark[last]==maxx[p].cnt&&last<maxx[p].value) )
          {
            break;       //找到新数字该插入的位置
          }

      p++;
   }
   if(p<k)
   {
       int pp=p;        //找找后面有没有他自己
       while(pp<k&&maxx[pp].value!=last) pp++;

       for(int i=pp-1;i>=p;i--)
       {
           maxx[i+1]=maxx[i];
       }
       maxx[p].value=last;
       maxx[p].cnt=mark[last];
   }
   printf("%d:",x);
   for(int i=0;i<k;i++)
   {  if(maxx[i].value==-1) break;
      printf(" %d",maxx[i].value);
   }
   last=x;
   cout<<endl;
}

int main()
{
    int n,k;
    for(int i=0;i<15;i++)
    {
       maxx[i].cnt=-1;
       maxx[i].value=-1;
    }
    cin>>n>>k;
    int tmp;
    cin>>tmp;
    last=tmp;
    for(int i=1;i<n;i++)
     {
         scanf("%d",&tmp);
         goin(tmp,k);
     }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值