2021-01-27

今天学习了有关动态规划的问题。其主要思想就是将一个主问题,也往往就是题目要求的问题转化成一系列子问题,然后根据状态的不同找到对应的状态转移方程从而将问题变成一个可以递推或者递归求解的问题,在解决子问题的同时从而解决主问题。下面放到例题。

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Input
abcfbc abfcab
programming contest
abcd mnp

Output
4
2
0

Sample Input
abcfbc abfcab
programming contest
abcd mnp

Sample Output
4
2
0

这题的关键实在找到求出最大共同子子字符串的转移方程,格式是一个二维数组的求出相邻的字符的最大子序列长度。代码如下。

#include<iostream>
#include<stack>
#include<stdio.h>
#include<string>
#include<algorithm>
#include<queue>
#include<math.h>
#include<string.h>
#include<string>
const int MAXN = 1e3;
using namespace std;
int a[MAXN],length_max[MAXN];
char s1[MAXN],s2[MAXN];
int len1,len2,max_len[MAXN][MAXN];
int main () {
	while(scanf("%s",s1)!=EOF) {
		memset(max_len,0,sizeof max_len);
		scanf("%s",s2);
		len1=strlen(s1);len2=strlen(s2);
		for( int i =0 ;i < len1 ; i++){
			for( int j =0;j < len2 ; j++){
				if(s1[i]==s2[j]){
					max_len[i+1][j+1]=max_len[i][j]+1;
				}
				else{
					max_len[i+1][j+1]=max(max_len[i+1][j],max_len[i][j+1]);
				}
			}
		}
		cout<<*max_element(&max_len[0][0],&max_len[len1+1][len2+1])<<endl;
	}
}

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

这是一道典型的背包模板例题,就是依次去放试探容量并取最大值。代码如下。

#include<iostream>
#include<stack>
#include<stdio.h>
#include<string.h>
#include<algorithm>
const int MAXN=1e4+15;
using namespace std;
int n,v,val[MAXN],vol[MAXN];
int main () {
	int t,sum[MAXN];
	cin>>t;
	while(t--){
		memset(sum,0,sizeof sum);
		scanf("%d%d",&n,&v);
		for(int i=1;i<=n;i++) {
		scanf("%d",&val[i]);
		}
		for(int i=1;i<=n;i++) {
			scanf("%d",&vol[i]);
		}
		for(int i=1;i<=n;i++){
			for(int j=v;j>=vol[i];j--){
				sum[j]=max(sum[j],sum[j-vol[i]]+val[i]);
			} 
			
		}
      cout<<sum[v]<<endl;
     
	}
	

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值