杭电 2602 Bone Collector——(裸)01背包、滚动数组

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
在这里插入图片描述

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

这是一道裸的01背包问题,也是最经典的一道01背包题目

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int dp[1010][1010];
int t, n, v;
struct node
{
    int vi, wi;
} w[1010];
int ans()
{
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= n; ++i)
        for (int j = 0; j <= v; ++j)
            if (w[i].wi > j)
                dp[i][j] = dp[i - 1][j]; //不选
            else
                dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - w[i].wi] + w[i].vi); //选
    return dp[n][v];
}
int main()
{
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &v);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].vi);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].wi);
        printf("%d\n", ans());
    }
    return 0;
}

滚动数组

  1. 我们可以把二维dp转换为一维dp以节省空间,我们观察二维表可以发现,每一行都是从上面一行算出来的,只跟上面一行有关系,与前面的行没有关系,那么用新的一行覆盖原来的一行就可以了
  2. 我们需要注意要把j反过来循环,也就是从后面往前面覆盖
  3. 优点:经过滚动数组的优化,空间复杂度就从O(NV)减少为O(V),动态规划题经常会给出很大的N、V,此时需要滚动数组,否则会MLE(空间超限)
  4. 缺点:无法构造最优解
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int dp[1010];
int t, n, v;
struct node
{
    int vi, wi;
} w[1010];
int ans()
{
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= n; ++i)
        for (int j = v; j >= w[i].wi; --j)
            dp[j] = max(dp[j], dp[j - w[i].wi] + w[i].vi);
    return dp[v];
}
int main()
{
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &v);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].vi);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].wi);
        printf("%d\n", ans());
    }
    return 0;
}
如何停止时间:亲吻
如何时间旅行:阅读
如何逃脱时间:音乐
如何感受时间:写作
如何释放时间:呼吸
人生一世便是要抓住生命里的每一分,每一秒,聆听自己内心深处的回响,在分秒中解读生命的奥义
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值