离散题目9
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description
给定一个数学函数F和两个集合A,B,写一个程序来确定函数是单射。
即A中的任意一个元素唯一的对应一个函数值,并且该值为B集合中的某个元素。
Input
多组输入。
首先输入集合的元素数n<=100000。
接下来的一行输入n 个整数0<=ai<=n。
接下来的一行输入n个整数 0<=bi<=n。
接下来的一行输入2n个整数ci,并且当ci的下标为奇数时表示A集合中的元素,当ci的下标为偶数时表示A集合中元素对应的函数值(即B集合的元素)。
Output
(一组答案占一行)
当满足单射关系时输出yes
不满足关系时输出no
Example Input
4
1 3 5 7
2 5 6 8
1 2 3 2 5 8 7 6
2
1 4
3 5
1 3 1 5
Example Output
yes
no
#include <stdio.h>
#include <string.h>
int a[100010],b[100010],c[100010],d[100010];
int main()
{
int n,x,y;
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for (int i=0; i<n; i++)
{
scanf("%d",&x);
a[x]=1;
}
for (int i=0; i<n; i++)
{
scanf("%d",&x);
b[x]=1;
}
int flag=1;
for (int i=0; i<n; i++)
{
scanf("%d %d",&x,&y);
a[x]++;
if (a[x]==2&&b[y]==1)
{
}
else
{
flag=0;
}
}
if (flag)
{
printf("yes\n");
}
else
{
printf("no\n");
}
}
return 0;
}