HDU-1074压状dp

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11729    Accepted Submission(s): 5620


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
 
 
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
 
 
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

题意:输入一个数字表示多少组,再输入一个数字表示作业有多少。前面是作业名字,后面是截止日期和做作业需要的时间,超过截止日期继续做作业的话会扣分,一天一分,问题是怎样扣的分最少。

思路:数据很小,最多16,用压状dp做(自己去找压状dp讲解的博客的时候发现很少,看来要自己整理一下了)

坑点:已经提示了,无坑点

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn=(1<<15)+10;
const int INF=0x7f7f7f7f;
int n;
int dp[maxn],day[maxn],pre[maxn],fina[20],fin[20];
char name[20][110];
void output(int x)
{
    if (x==0)
        return ;
    output(x-(1<<pre[x]));    //x-(1<<pre[x])表示 第pre[x]作业做完了
    cout<<name[pre[x]]<<endl;
    return ;
}
int main()
{
    int t,i,j;
    while (cin>>t&&t)
        while (t--)
            {
                cin>>n;
                for (i=0;i<n;i++)
                    scanf("%s%d%d",&name[i],&fina[i],&fin[i]);
                int sum=1<<n,temp,score;            //sum表示所有情况全部考虑
                for (i=1;i<sum;i++)                //全部遍历 
                    {
                        dp[i]=INF;                //表示扣最少的分,开局999999 
                        for (j=n-1;j>=0;j--)
                            {
                                temp=1<<j;        //这里把做第j个作业转换成二进制(0表示没做,1表示做了)
                                if (!(i&temp))    //如果j作业在遍历中没做的话,不需要考虑
                                    continue;
                                score=day[i-temp]+fin[j]-fina[j];        //score表示没做j之前扣的分加上做j扣的分
                                if (score<0)                            //扣分不可能小于0(老师不可能给你加分的)
                                    score=0;
                                if (dp[i]>dp[i-temp]+score)            // 更新dp[i]的数据
                                    {
                                        dp[i]=dp[i-temp]+score;
                                        day[i]=day[i-temp]+fin[j];    //day表示到第i种情况完成的天数
                                        pre[i]=j;                    //这里的pre表示第i种情况之前做的是什么作业
                                    }
                            }
                    }
                cout<<dp[sum-1]<<endl;
                output(sum-1);
            }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值