poj2386Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

题意:有一个大小为N*M的院子,雨后积起了水。八连通的积水被认为连接在一起,(即属于一个水洼)。求院子共有多少水洼.

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,ans,nx,ny;
char map[110][110];
int used[110][110];
void dfs(int x,int y)
{
	map[x][y]='.';//这里直接将其现在所在位置替换为'.'。以免下次重复搜索 
	for(int dx=-1;dx<=1;dx++)
	for(int dy=-1;dy<=1;dy++){
		int nx=x+dx,ny=y+dy;
		if(nx>=0&&nx<n&&ny>=0&&ny<m&&map[nx][ny]=='W')
		{

		dfs(nx,ny);	
		}
		
	}
	return ;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j;
		memset(used,0,sizeof(used));
		ans=0;
		for(i=0;i<n;i++)
		scanf("%s",map[i]);
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='W')
				{
				
					dfs(i,j);
					ans++;
				}
			}
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值