Monthly Expense(二分)

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Difficulty:二分,mid(即最小money)与组数M成单调递减的函数,对mid进行二分。

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,mid,high,low,f;
int a[100005];
int judge(int x)
{int count=1;int sum=0;//count为组数计量
    for(int i=0;i<m;i++)
    {if(sum+a[i]<=mid)//前i天比mid值小,合为一组。
    sum+=a[i];
    else//前i天比mid大,那前i-1天已经成为一组,第i天作为下一组的开始
    {
        sum=a[i];
        count++;
    }
}
if(count>n)//组数计量大于题目所要求组数,说明mid值偏小
return 1;
else//反之,说明mid值偏大
return 0;
}
int main()
{
 while(~scanf("%d%d",&m,&n))
 {high=low=mid=f=0;
 for(int i=0;i<m;i++)
 {scanf("%d",&a[i]);
  high+=a[i];//最大值的情况组数为1
  if(low<a[i])
  low=a[i]; //最小值的情况组数n=m
 }
 if(n==1)
 {printf("%d",high);f=1;}
 if(n==m)
 {printf("%d",low);f=1;
 }
 if(f==0)
 {mid=(high+low)/2;//开始进行二分;
     while(low<high)
 {
     if(judge(mid))//可能在low==high之前,满足了题目所要求的组数,但不是最优解,继续二分,mid的值是一步一步减小或增大(即-1或+1)当low=high时,即最优解。
     low=mid+1;
     else
     high=mid-1;
     mid=(high+low)/2;//调整这个式可以微调答案。
 }
 printf("%d\n",mid);}}
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值