BestCoder Round #85题解报告

1.sum(杭电5776)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 772    Accepted Submission(s): 363


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 , 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 

Source
 

【题意】
给定一个数列,问是否存在连续子串的和为m的倍数


【类型】
预处理前缀和

【分析】
所谓预处理前缀和

顾名思义,就是将前i项的和相加对m取模保存至sum[i]

这时,当某两个位置的模数一样时,此区间内所有数之和必定为m的倍数

为什么呢?证明一下

假设sum[i]=sum[j],则

BestCoder Round #85题解报告

特别的,若某前缀和取模后为0,意味着数列从头到当前位置所有元素之和已为m的倍数


Recommend
wange2014   |   We have carefully selected several similar problems for you:   5780  5779  5778  5777  5775 
#include<stdio.h>
#include<string.h>
int main()
{
int t,n,m,i;
int a[100010],b[100010],visit[100010];
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
int sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
b[i]=sum%m;
}
memset(visit,0,sizeof(visit));
for(i=0;i<n;i++)
{
if(b[i]==0||visit[b[i]])
{
printf("YES\n");
break;
}
else
visit[b[i]]=1;
}
if(i==n)
printf("NO\n");
}
return 0;
}
 

2.domino(杭电5777)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 539    Accepted Submission(s): 277


Problem Description
Little White plays a game.There are n pieces of dominoes on the table in a row. He can choose a domino which hasn't fall down for at most k times, let it fall to the left or right. When a domino is toppled, it will knock down the erect domino. On the assumption that all of the tiles are fallen in the end, he can set the height of all dominoes, but he wants to minimize the sum of all dominoes height. The height of every domino is an integer and at least 1.
 

Input
The first line of input is an integer T ( 1T10 )
There are two lines of each test case.
The first line has two integer n and k, respectively domino number and the number of opportunities.( 2k,n100000 )
The second line has n - 1 integers, the distance of adjacent domino d, 1d100000
 

Output
For each testcase, output of a line, the smallest sum of all dominoes height
 

Sample Input
   
   
1 4 2 2 3 4
 

Sample Output
   
   
9
 

Source
 

Recommend
wange2014

解题思路:

【题意】
n张多米诺骨牌排成一列,你可以选k张推倒,现给你相邻骨牌之间的距离,问在保证所有骨牌都能推倒的情况下,所有骨牌的高度之和最小为多少


【类型】
排序

【分析】
首先,在只推一次的情况下,骨牌i的高度hi必须满足hi>=di+1(di为骨牌i和骨牌i+1之间的距离)

而每多推一次,其实只能消去一个间距罢了

那为了骨牌高度之和尽可能小,那必定是要消去间距大的

故将间距排序之后,去掉最大的k-1个即可

特别的,当k>=n时,因为至少每个骨牌都可以单独推,所有骨牌高度与间距无关,只需满足题目要求的骨牌高度至少为1即可

需注意,结果可能会爆int


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值