sum——数论抽屉原理

Problem Description

Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

Input

The first line of the input has an integer T (), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m (, ).
2.The second line contains n positive integers x () according to the sequence.

Output

Output T lines, each line print a YES or NO.

Sample Input

2 3 3 1 2 3 5 7 6 6 6 6 6

Sample Output

YES NO

 

 

https://blog.csdn.net/qiqi_skystar/article/details/52088149

解题思路:(官方题解)

预处理前缀和,一旦有两个数模m的值相同,说明中间一部分连续子列可以组成m的倍数。 另外,利用抽屉原理,我们可以得到,一旦n大于等于m,答案一定是YES 复杂度 O(n)

解释一下:

举个例子:

4%3=1

10%3=1

那么10-4=6是可以被3整除的。

也就是说只要这个余数出现过两次,那么必定存在一个连续的子序列可以组成m的倍数。

 

代码

#include<bits/stdc++.h>
using namespace std;

int sum[100005],vis[5005];

int main(){
	int t,a,n,m,k;
	cin>>t;
	while(t--){
		cin>>n>>m;
		int flag=0;
		memset(vis,0,sizeof(vis));
		memset(sum,0,sizeof(sum));
		vis[0]=1; //关键一步,一定要记得能直接模等于0一定可以!!!vis[0]=1!!!
		for(int i=1;i<=n;i++){
			cin>>a;
			sum[i]=sum[i-1]+a;
		}
		for(int i=1;i<=n;i++){
			k=sum[i]%m;
			if(vis[k]==1){
				flag=1;
				break;
			}
			vis[k]=1;
		}
		if(flag) cout << "YES" <<endl;
		else cout << "NO" <<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值