题目链接:点击打开链接
7-11 How Long Does It Take(25 分)
Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i
-th activity, three non-negative numbers are given: S[i]
, E[i]
, and L[i]
, where S[i]
is the index of the starting check point, E[i]
of the ending check point, and L[i]
the lasting time of the activity. The numbers in a line are separated by a space.
Output Specification:
For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".
Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
Sample Output 1:
18
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:
Impossible
拓扑排序
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m;
int in[110],map[110][110],cost[110];
int main()
{
int i,j,a,b,u,max;
scanf("%d %d",&n,&m);
for(i=0;i<n;i++)
{
in[i]=0;
cost[i]=-1;
for(j=i;j<n;j++)
map[i][j]=map[j][i]=-1;
}
queue<int>q;
while(m--)
{
scanf("%d%d%d",&a,&b,&u);
in[b]++;
map[a][b]=u;
}
for(i=0;i<n;i++)
if(in[i]==0)
{
q.push(i);
cost[i]=0;
}
while(!q.empty())
{
u=q.front();
q.pop();
for(i=0;i<n;i++)
{
if(map[u][i]!=-1)
{
in[i]--;
if(cost[i]<cost[u]+map[u][i])
cost[i]=cost[u]+map[u][i];
if(in[i]==0)
q.push(i);
}
}
}
max=-1;
for(i=0;i<n;i++)
{
if(in[i])//成环
break;
if(cost[i]>max)
max=cost[i];
}
if(i==n)
printf("%d\n",max);
else
printf("Impossible\n");
return 0;
}