数据结构课设第八周 7-1

How Long Does It Take (25分)

又到了英语题 一句一句翻译的时候了
被好多大佬搜到了我纯copy的这个代码 惭愧 听大佬讲解之后 那我再补充一点吧 ——2020.4.21

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.
给定项目所有活动的关系,您应该找到项目的最早完成时间。

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.
每个输入文件包含一个测试用例。每种情况都从包含两个正整数N(≤100)的行开始,N是活动性检查点的数目(因此,假设检查点的编号是从0到N-1),而M是活动性数目。然后紧跟着M行,每行给出了活动的描述。对于第i个活动,给出了三个非负数:S [i],E [i]和L [i],其中S [i]是起始检查点的索引,E [i]为结束检查点,L [i]活动的持续时间。一行中的数字用空格分隔。

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.
对于每个测试用例,如果可以安排时间,请在一行中打印其最早完成时间;或简单地输出“不可能”。

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

没时间解释了 先copy一个

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>

using namespace std;

const int maxn = 505;
int map[maxn][maxn], dis[maxn];
int in[maxn];
int n, m;
int toposort();

int main(){
	memset(dis, 0, sizeof(dis));
	memset(in, 0, sizeof(in));
	memset(map, -1, sizeof(map));
	scanf("%d %d", &n, &m);
	int from, to, cost;
	for(int i = 0;i < m ; i++){
		scanf("%d %d %d", &from, &to, &cost);
		map[from][to] = cost;
		in[to]++;
	}
	int ans = toposort();
	if(ans) printf("Impossible\n");
	else{
		int max1 = -1;
		for(int i = 0;i < n ; i++){
			if(max1 < dis[i]){
				max1 = dis[i];
			}
		}
		printf("%d", max1);
	}
	return 0;
}

int toposort(){
	queue<int> que;
	memset(dis, 0, sizeof(dis));
	int cnt = 0;
	for(int i = 0;i < n; i++){ 
		if(in[i] == 0){
			que.push(i);
		}
	}
	while(!que.empty()){
		int v = que.front();
		cnt++;
		que.pop();
		for(int i = 0;i < n ; i++){
			if(map[v][i] != -1){
				dis[i] = max(dis[i],map[v][i] + dis[v]);
				if(--in[i] == 0) que.push(i);
			}
		}
	}
	if(cnt == n) return 0;
	else return 1;
}

补充2020.4.21:
这个题的三个数应该是有向图起点、有向图终点、消耗时间。
拓扑排序可以看看这篇文章
经过拓扑排序之后,会对所有的节点进行一个排序。
然后经过累加得到哪一个花的时间是最多的。
最后得到最多花费时间。
先更新这些,希望后面搜到的大佬能多提供点帮助吧。
以及我真的是小菜鸡,希望大佬可以带带我一起进步。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值