杭电2899Strange fuction 求导+二分

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4788    Accepted Submission(s): 3413


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 
求导加二分,当导函数等于0时,该式取得最小值;
附ac代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
	double x,y,a,b,i,j;
	int main()
	{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		double left=0;
		double right=100;
		int m=100;
		while(m--)//循环100次基本能精确到小数点后不知多少位了. 
		{
		a=(left+right)/2;
			if(42*a*a*a*a*a*a+48*a*a*a*a*a+21*a*a+10*a-y>0)//pow函数好像不能用,因为不是整形的 
			right=a;//当当前导函数大于0时,往 左侧查找 
			if(42*a*a*a*a*a*a+48*a*a*a*a*a+21*a*a+10*a-y<0)
			left=a;//当当前导函数小于0时,往 右侧查找 
		}
		//printf("%.6lf\n",a);
		double ans=6*a*a*a*a*a*a*a+8*a*a*a*a*a*a+7*a*a*a+5*a*a-y*a;
		printf("%.4lf\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值