杭电2122Ice_cream’s world III

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1356    Accepted Submission(s): 453


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
  
  
2 1 0 1 10 4 0
 

Sample Output
  
  
10 impossible
 

Author
Wiskey
 
好久没写代码了,挺简单的一道题,不知道为啥么没人做,就是最基础的最小生成树,这里用的最小生成树的库鲁斯卡尔算法,该算法用的并查集,很基础很重要的算法 ;
附ac代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std; 
struct node
{
	int start;
	int end;
	int cost;
}t[100100];
int per[10001];
int cmp(node a,node b)
{
	return a.cost<b.cost;
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	r=per[r];
	return r;
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;
		return 1;
	}
	return 0;
}
int main()
{
	int i,j,k,l,m,n;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		for(i=0;i<10001;i++)
		per[i]=i;
		for(i=0;i<n;i++)
		scanf("%d%d%d",&t[i].start,&t[i].end,&t[i].cost);
		sort(t,t+n,cmp);
		int ans=0;
		for(i=0;i<n;i++)
		{
			if(join(t[i].start,t[i].end))
			ans+=t[i].cost;
		}
		int flag=0;
		for(i=0;i<m;i++)
		if(per[i]==i)
		flag++;
		if(flag>1)
		printf("impossible\n\n");
		else
		printf("%d\n\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值