杭电 最小生成树 2122 Ice_cream’s world III


Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1446    Accepted Submission(s): 494


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
  
  
2 1 0 1 10 4 0
 

Sample Output
  
  
10 impossible
 

这个题目的要求和 Ice_cream’s world II一样,要求遍历所有的点。另外要求保证只有一条道路。

看到了遍历所有的点,我们直接就想到了最小生成树。直接上代码即可:


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct dian
{
    int x,y,dis;
}a[121212];
int cmp(dian a,dian b)
{
    return a.dis<b.dis;
}
int f[121212];
int find(int a)
{
    int r=a;
    while(f[r]!=r)
    r=f[r];
    int i=a;
    int j;
    while(i!=r)
    {
        j=f[i];
        f[i]=r;
        i=j;
    }
    return r;
}
int merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(f,0,sizeof(f));
        for(int i=0;i<n;i++)
        {
            f[i]=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].dis);
        }
        sort(a,a+m,cmp);
        int output=0;
        for(int i=0;i<m;i++)
        {
            if(find(a[i].x)!=find(a[i].y))
            {
                merge(a[i].x,a[i].y);
                output+=a[i].dis;
            }
        }
        int flag=0;
        for(int i=0;i<n;i++)
        {
            //printf("%d ",f[i]);
            if(f[i]==i)flag++;
        }
        printf("\n");
        if(flag==1)
        {
            printf("%d\n\n",output);
        }
        else
            printf("impossible\n\n");
    }
}


















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值