poj3259Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 37403 Accepted: 13757

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source


判断有没有负环,用spfa算法,当然用贝尔曼福特算法也行。


附代码:

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
#include<queue>
#define INF 0x3f3f
#include<string.h>
#define MAXN 2000
#define MAXM 20010
struct Edge
{
 int from,to,val,next;
}edge[MAXM];
int dist[MAXN],vis[MAXN],head[MAXN],used[MAXN];
int n,m,top=0,k,flag;
void init() 
{
    memset(vis,0,sizeof(vis));
    memset(dist,INF,sizeof(dist));
    memset(head,-1,sizeof(head));
    memset(used,0,sizeof(used));
}
void addEdge(int u,int v,int w) 
{
    edge[top].from=u;
    edge[top].to=v;
    edge[top].val=w;
    edge[top].next=head[u];
    head[u]=top++;
}
int spfa(int sx)
{
    flag=0;
    queue<int>Q;
    Q.push(sx);
    dist[sx]=0;
    vis[sx]=1;
    used[sx]=1;
    while(!Q.empty() )
    {
        int u=Q.front();
        Q.pop() ;
        vis[u]=0;
        for(int i=head[u];i!=-1;i=edge[i].next )
        {
            int v=edge[i].to ;
            if(dist[v]>dist[u]+edge[i].val )
            {
                dist[v]=dist[u]+edge[i].val ;
                if(!vis[v])
                {
                    vis[v]=1;
                    Q.push(v); 
                    used[v]++;
                    if(used[v]>n)
                    {
                        flag=1;
                        return 1;
                    }
                }
            }
        }
    }
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        init();
        top=0;
        int u,v,w;
    scanf("%d%d%d",&n,&m,&k);
    while(m--)
    {
        scanf("%d%d%d",&u,&v,&w); 
        addEdge(u,v,w);
        addEdge(v,u,w);
    }   
    while(k--)
    {
        scanf("%d%d%d",&u,&v,&w);
        addEdge(u,v,-w);
    }
      int s=spfa(1);
      if(s)
      printf("YES\n");
      else
      printf("NO\n");
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值