How Many Trees?

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4555 Accepted Submission(s): 2534


Problem Description

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?

 


Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.


Sample Input

1 2 3

Sample Output

1 2 5


Source

UVA

 

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <cassert>
using namespace std;
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
typedef vector<int> VI;
typedef long long ll;
typedef pair<int, int> PII;
typedef pair<long, long> PLL;
const ll mod = 1000000007;
const int N = 5e5 + 5; // 矩阵最大维数
int n;
int a,b;
ll dp[105][444];
int main() {
	//dp1[0]=0,dp2[0]=0;
	memset(dp,0,sizeof(dp));
	dp[0][0]=1,dp[1][0]=1,dp[2][0]=2,dp[3][0]=5; 
	rep(i,4,101){
		int c=0;int j;
		for( j=0; j<444; j++){
			dp[i][j] = dp[i-1][j]*(4*i-2) + c;
			c= dp[i][j]/10; dp[i][j]%=10;
		}
		
		c=0;j=443;
		while(dp[i][j]==0) j--;
		for( ;j>=0;j--){
			if(dp[i][j]+c < (i+1)){
				c = (c+dp[i][j])*10;
				dp[i][j]=0;
			}
			else{
				int cc=dp[i][j]+c;
				dp[i][j]=cc/(i+1);
				c = cc%(i+1)*10;
			}
		}
	}
	
//	rep(i,1,101){
//		int j;
//		for(j=443;j>0;j--){
//			if(dp[i][j]) break;
//		}
//		for(;j>=0;j--){
//			cout<<dp[i][j];
//		}
//		cout<<'\n';
//	}
	
	while(cin>>n){
		int j;
		for(j=443;j>0;j--){
			if(dp[n][j]) break;
		}
		for(;j>=0;j--){
			cout<<dp[n][j];
		}
		cout<<'\n';
	}
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值