杭电1165

Eddy's research II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3845    Accepted Submission(s): 1417


Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
 

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.
 

Output
For each value of m,n, print out the value of A(m,n).
 

Sample Input
  
  
1 3 2 4
 

Sample Output
  
  
5 11
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1158  1074  1208  1355  1025 
 



我没有那么机智,只能推出来a[1][n]=n+2;后边的就退不出来了,但是自己写了一个递归,输入几个数找规律就解决了:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[5][1100000],i,j,k,l,m,n;
int dfs(int m,int n)
{
	if(m==0)
	return n+1;
	if(n==0)
	return dfs(m-1,1);
	return dfs(m-1,dfs(m,n-1));
}
int main()
{
	for(i=0;i<1100000;i++)
	a[0][i]=i+1;
	for(i=0;i<1100000;i++)
	a[1][i]=i+2;
	for(i=0;i<1100000;i++)
	a[2][i]=2*i+3;
	a[3][0]=5;
	for(i=1;i<=24;i++)
	a[3][i]=a[3][i-1]*2+3; 
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		printf("%d\n",a[m][n]);
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值