杭电1242Rescue(深搜)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22277    Accepted Submission(s): 7914


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1240  1010  1072  1253  1372 
 




本应该是一个广搜+优先队列的好题,但是我不大会广搜,就用深搜过了,倒着想就行了,从天使开始找,找他的朋友。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[220][220];
int i,j,k,l,m,n,num,best;
void dfs(int x,int y)
{	
	if(map[x][y]=='#')
	return ;
	if(x<0||x>m||y<0||y>n)
	return ;
	if(map[x][y]=='a')
	{
		dfs(x,y+1);
		dfs(x,y-1);
		dfs(x+1,y);
		dfs(x-1,y);
	}
	
	if(map[x][y]=='x')
	{
		num++;
		num++;
		map[x][y]='#';
		dfs(x,y+1);
		dfs(x,y-1);
		dfs(x+1,y);
		dfs(x-1,y);
		map[x][y]='x';
		num--;
		num--;
	}
	
	if(map[x][y]=='r')
	{
	if(best>num)
	best=num;
	}
	
	
	if(map[x][y]=='.')
	{
		num++;
		map[x][y]='#';
		dfs(x,y+1);
		dfs(x,y-1);
		dfs(x+1,y);
		dfs(x-1,y);
		map[x][y]='.';
		num--;
	}
}
int main()
{
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		for(i=0;i<m;i++)
		scanf("%s",map[i]);
		best=99999;
		for(i=0;i<m;i++)
		for(j=0;j<n;j++)
		{
		num=0;
		if(map[i][j]=='a')
		dfs(i,j);
		}
		if(best!=99999)
		printf("%d\n",best+1);
		else
		printf("Poor ANGEL has to stay in the prison all his life.\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值