HDU 1242 Rescue(图)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24660    Accepted Submission(s): 8704


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1240  1016  1010  1072  1241 

BFS
大致思路:输入基本数据,找到朋友和天使的位置,即起点和终点。
然后以朋友位置为起点向四个方向遍历整个图,记录下到达每个位置 的最短时间,最后输出到达天使位置所记录的最短时间。
这个时间为无穷大时(程序中设的,也可以不这样做)不能到达天使位置。


#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
#include<algorithm>
#define INF 1000000  //极大值 
using namespace std;
struct point{
	int x,y;   //坐标 
	int step;  //步数 
	int time;  //时间 
};
int n,m;
char map[205][205];   //图 
int mintime[205][205];   //最小用时 
int dir[4][2]={{-1,0},{0,1},{1,0},{0,-1}};  //四个方向 
int ax,ay;     //天使的坐标 
queue<point>Q;
int bfs(point s){
	int i,x,y,j;
	Q.push(s);
	point hd;
	while(!Q.empty()){    //为空即遍历过全图 
		hd=Q.front();   
		Q.pop();
		for(i=0;i<4;i++){  //分别找四个方向 
			x=hd.x+dir[i][0]; 
			y=hd.y+dir[i][1];
			if(x>=0&&x<=n-1&&y>=0&&y<=m-1&&map[x][y]!='#'){  //超界的情况和撞墙 排除 
				point next;     //找到的下一个位置 
				next.x=x; next.y=y; 
				next.step=hd.step+1;
				next.time=hd.time+1;
				if(map[x][y]=='x')  //遇到士兵,时间多加一 
					next.time++;
				if(next.time<mintime[x][y]){  //找到最短用时 
					mintime[x][y]=next.time;
					Q.push(next);   //最短用时的位置入队  
				}
			}
		}
	}
	return mintime[ax][ay];  //返回 到达天使位置的最短用时 
}  //这里遍历了整个图,可以返回到达任意位置的最短用时 
int main(){
	int i,j,mint;
	while(scanf("%d%d",&n,&m)!=EOF){
		memset(map,0,sizeof(map));
		for(i=0;i<n;i++)
			scanf("%s",map[i]);
			int sx,sy;
			point st;
		for(i=0;i<n;i++){
			for(j=0;j<m;j++){
				mintime[i][j]=INF;
				if(map[i][j]=='r'){
					sx=i;sy=j;
				}
				else if(map[i][j]=='a'){
					ax=i;ay=j;
				}
			}
		}
		st.x=sx; st.y=sy;
		st.step=0;  st.time=0;
		mintime[sx][sy]=0;
		mint=bfs(st);
		if(mint<INF) printf("%d\n",mint);  
		else printf("Poor ANGEL has to stay in the prison all his life.\n"); // 到达不了天使位置,即用时无穷大时 
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值